[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH V8 3/7] libxl: add pvusb API

On Wed, 2015-11-18 at 10:44 +0100, Olaf Hering wrote:
> On Tue, Nov 17, Chun Yan Liu wrote:
> > I think libxl_device_usb doesn't need to be changed into
> > libxl_device_usbdev? 
> In case of vscsi the struct and functions names are odd. It was not
> obvious which one belongs to a ctrl and which one belongs to a device.
> In the meantime I have changed everything related to a scsi host, it
> contains now 'vscsictrl'. The names related to devices will follow.
> I suggest to do apply the same also to usb and make it clear what
> belongs to a ctrl and what to a device. Havent checked your patch what
> places that actually would be.

Whatever you guys decide on please make sure the model used for these two
device types are consistent with each other (and potentially other future
device kinds using this model) and where it makes sense consistent with the
controller-less device types whose template set of operations is already
defined in libxl.h

I'd been hoping that someone involved ion this would generate a patch
adding a template for this controller+devices model to libxl.h, I've not
seen anything since George's original RFC[0] "libxl: Introduce a template
for devices with a controller".


[0] <1432228052-15667-1-git-send-email-george.dunlap@xxxxxxxxxxxxx>

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.