[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] boot xen use legacy bios

I'm tring to solve the "no console"  problem "only one core" problem with guide of  http://lists.xenproject.org/archives/html/xen-users/2013-03/msg00239.html 

These is the information:
df -h
/dev/sda1                     511M   31M  481M   7% /boot/efi

~/boot/efi$ du
3420    ./EFI/ubuntu
8       ./EFI/Dell/BootOptionCache
12      ./EFI/Dell
28268   ./EFI/xen        //this is where i put the xen related files
31704   ./EFI
31708   .

/boot/efi/EFI$ ls xen
initrd.img-3.13.0-24-generic  vmlinuz-3.13.0-24-generic  xen.cfg  xen.efi

xen$ cat xen.cfg
options=console=vga,com1 com1=57600 loglvl=all noreboot dom0_mem=8g,max:8g
kernel=vmlinuz-3.13.0-24-generic root=/dev/mapper/xen--vg-root ro #earlyprintk=xen

However, the 'efibootmgr' cmd fails as follows and the UEFI shell could only detect the ubuntu item as http://snag.gy/hSnDs.jpg  shows.

    'efibootmgr -v' outputs
Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
Try 'modprobe efivars' as root.
I'm probably in a compatitable bios mode instead of the UEFI native boot is actually used using the detecting method.

Any hints? Is the config wrong or the location?

Date: 2015-11-29 19:26
Subject: [Xen-devel] boot xen use legacy bios
I got the problem of multiple cores CPU cannot be fully used when using UEFI mode. It is suggested that I should be boot the xen in legacy mode. How is it done? 
My environment: Xen 4.1.2, PowerEdge R730xd E5-2603 v3 @ 1.60GHz, ubuntu 14.04 kernel 3.13.0-24-generic
Some References I use:

Here are the files  in /boot/efi/EFI/xen$ ls
initrd.img-3.13.0-24-generic          xen-4.4.1.cfg  xen-4.4.1.gz
vmlinuz-3.13.0-24-generic.efi.signed  xen-4.4.1.efi

And the content of xen.4.4.1.cfg
options=console=vga,com1 com1=57600 loglvl=all noreboot
kernel=xen-4.4.1.efi root=/dev/sda1 ro console=tty1 console=hvc0

When I run "efibootmgr -w -L Xen -l "\EFI\Xen\xen.efi" -c",  it shows:
$ efibootmgr -w -L Xen -l "\EFI\Xen\xen-4.4.1.efi" -c
Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
Try 'modprobe efivars' as root.

I tried modprobe efiwars and still generate the same error. Directly reboot the system from BIOS doesn't success.

Any suggestions?
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.