[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v3 1/4] xen/save: pass a size parameter to the HVM compat functions

>>> On 24.11.15 at 13:54, <roger.pau@xxxxxxxxxx> wrote:
> El 20/11/15 a les 16.37, Jan Beulich ha escrit:
>>>>> On 18.11.15 at 17:37, <roger.pau@xxxxxxxxxx> wrote:
>>> --- a/xen/include/xen/hvm/save.h
>>> +++ b/xen/include/xen/hvm/save.h
>>> @@ -60,6 +60,8 @@ void _hvm_read_entry(struct hvm_domain_context *h,
>>>   */
>>>  #define _hvm_load_entry(_x, _h, _dst, _strict) ({                       \
>>>      int r;                                                              \
>>> +    struct hvm_save_descriptor *d                                       \
>>> +        = (struct hvm_save_descriptor *)&(_h)->data[(_h)->cur];         \
>> This would seem to belong in the else if() body below. Also I
>> don't think "d" is a suitable name for a variable inside a macro
>> (albeit the same would apply to "r" too).
> Patch #2 makes use of "d" in the first "if" branch also. I don't think
> it makes much sense to put it inside of the "else if" branch if I have
> to move it in the following patch.

Yes, I saw that, and while you could move in patch 2 I agree it
doesn't make much sense.

> Regarding the name, I don't have a strong opinion, desc is more
> descriptive, but it's also longer which means I might have to break some
> lines inside of the macro even more.

At least d_ perhaps then?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.