[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 5/5] drivers/xen: make platform-pci.c explicitly non-modular
On Sun, 14 Feb 2016, Paul Gortmaker wrote: > The Kconfig currently controlling compilation of this code is: > > arch/x86/xen/Kconfig:config XEN_PVHVM > arch/x86/xen/Kconfig: def_bool y > > ...meaning that it currently is not being built as a module by anyone. > > Lets remove the modular code that is essentially orphaned, so that > when reading the driver there is no doubt it is builtin-only. > > Since module_init translates to device_initcall in the non-modular > case, the init ordering remains unchanged with this commit. > > Also note that MODULE_DEVICE_TABLE is a no-op for non-modular code. > > We also delete the MODULE_LICENSE tag etc. since all that information > was (or is now) contained at the top of the file in the comments. > > Cc: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx> > Cc: Boris Ostrovsky <boris.ostrovsky@xxxxxxxxxx> > Cc: David Vrabel <david.vrabel@xxxxxxxxxx> > Cc: xen-devel@xxxxxxxxxxxxxxxxxxxx > Signed-off-by: Paul Gortmaker <paul.gortmaker@xxxxxxxxxxxxx> > --- > drivers/xen/platform-pci.c | 16 ++++++---------- > 1 file changed, 6 insertions(+), 10 deletions(-) > > diff --git a/drivers/xen/platform-pci.c b/drivers/xen/platform-pci.c > index 3454973dc3bb..302232518c98 100644 > --- a/drivers/xen/platform-pci.c > +++ b/drivers/xen/platform-pci.c > @@ -2,6 +2,9 @@ > * platform-pci.c > * > * Xen platform PCI device driver > + * > + * Authors: ssmith@xxxxxxxxxxxxx and stefano.stabellini@xxxxxxxxxxxxx > + * > * Copyright (c) 2005, Intel Corporation. > * Copyright (c) 2007, XenSource Inc. > * Copyright (c) 2010, Citrix > @@ -24,7 +27,7 @@ > > #include <linux/interrupt.h> > #include <linux/io.h> > -#include <linux/module.h> > +#include <linux/init.h> > #include <linux/pci.h> > > #include <xen/platform_pci.h> > @@ -36,10 +39,6 @@ > > #define DRV_NAME "xen-platform-pci" > > -MODULE_AUTHOR("ssmith@xxxxxxxxxxxxx and stefano.stabellini@xxxxxxxxxxxxx"); > -MODULE_DESCRIPTION("Xen platform PCI device"); > -MODULE_LICENSE("GPL"); > - > static unsigned long platform_mmio; > static unsigned long platform_mmio_alloc; > static unsigned long platform_mmiolen; > @@ -181,8 +180,6 @@ static struct pci_device_id platform_pci_tbl[] = { > {0,} > }; > > -MODULE_DEVICE_TABLE(pci, platform_pci_tbl); > - > static struct pci_driver platform_driver = { > .name = DRV_NAME, > .probe = platform_pci_init, > @@ -192,9 +189,8 @@ static struct pci_driver platform_driver = { > #endif > }; > > -static int __init platform_pci_module_init(void) > +static int __init platform_pci_xen_init(void) Maybe platform_pci_register? Or rename platform_pci_init to platform_pci_probe and this to platform_pci_init. > { > return pci_register_driver(&platform_driver); > } > - > -module_init(platform_pci_module_init); > +device_initcall(platform_pci_xen_init); > -- > 2.6.1 > _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |