[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xen-utils not running within xen or no compatible utils

On Fri, Apr 01, 2016 at 05:07:42PM +0200, aicha hamza wrote:
> hello
> i build xen from the source
> git clone git://xenbits.xen.org/xen.git
> xen run in omap 5 board with ubuntu  file system
> i'm looking of download some guests but there is no internet connection so
> i install xen tools by downloading xen-tools.deb then with dpkg command i
> install it
> but while doing the same steps to xen-utils-common i get this error
> Preparing to unpack xen-utils-common_4.5.0-1ubuntu4.4_all.deb ...
>  * Not running within Xen or no compatible utils
> i'have tried other versions but still the same problem
> and when i write xl ..i get
> ERROR:  Can't find version 4.7 of xen utils, bailing out!

In short, you can't mix and match deb binaries and source compiled
binaries. Even if you manage to install them, they won't work
together properly.

One way to work around that is to download whatever files / repositories
xen.git need and put them in the right location.


> does any body can help me
> Regards

> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxx
> http://lists.xen.org/xen-devel

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.