[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [Xen-devel] [PATCH 0/6] libxl: add HVM USB passthrough capability
Add the capability to pass USB devices to HVM domains by using the emulation of USB controllers of qemu. The user interface via xl is the same as for pvusb passthrough, only the type of the usbctrl is different: instead of "qusb" (qemu-based pvusb backend) or "vusb" (kernel-based pvusb backend) the type "devicemodel" is used. Especially the communication with qemu via qmp commands is based on the patches of George Dunlap sent in 2014: https://lists.xen.org/archives/html/xen-devel/2014-06/msg00085.html Juergen Gross (6): libxl: rename libcl_pvusb.c to libxl_usb.c libxl: add libxl__qmp_run_command_flexarray() function libxl: dont pass array size to libxl__xs_kvs_of_flexarray() libxl: add basic support for devices without backend libxl: add HVM usb passthrough support docs: add HVM USB passthrough documentation docs/man/xl.cfg.pod.5.in | 12 +- tools/libxl/Makefile | 2 +- tools/libxl/libxl.c | 22 +- tools/libxl/libxl_device.c | 62 +++-- tools/libxl/libxl_internal.h | 5 +- tools/libxl/libxl_nic.c | 6 +- tools/libxl/libxl_pci.c | 7 +- tools/libxl/libxl_qmp.c | 16 ++ tools/libxl/libxl_types_internal.idl | 1 + tools/libxl/{libxl_pvusb.c => libxl_usb.c} | 423 ++++++++++++++++++++++------- tools/libxl/libxl_vtpm.c | 6 +- tools/libxl/libxl_xshelp.c | 8 +- tools/libxl/xl_cmdimpl.c | 4 +- 13 files changed, 429 insertions(+), 145 deletions(-) rename tools/libxl/{libxl_pvusb.c => libxl_usb.c} (80%) -- 2.6.6 _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx https://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |