[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 4/7] x86/traps: Rename compat_hypercall() to entry_int82()



>>> On 02.05.17 at 20:05, <andrew.cooper3@xxxxxxxxxx> wrote:
> --- a/xen/arch/x86/traps.c
> +++ b/xen/arch/x86/traps.c
> @@ -3872,7 +3872,7 @@ void __init trap_init(void)
>  
>      /* The 32-on-64 hypercall vector is only accessible from ring 1. */
>      _set_gate(idt_table + HYPERCALL_VECTOR,
> -              SYS_DESC_trap_gate, 1, &compat_hypercall);
> +              SYS_DESC_trap_gate, 1, &entry_int82);

Would you mind at once dropping the unnecessary & ?

> --- a/xen/include/asm-x86/processor.h
> +++ b/xen/include/asm-x86/processor.h
> @@ -529,6 +529,8 @@ DECLARE_TRAP_HANDLER(simd_coprocessor_error);
>  DECLARE_TRAP_HANDLER_CONST(machine_check);
>  DECLARE_TRAP_HANDLER(alignment_check);
>  
> +DECLARE_TRAP_HANDLER(entry_int82);

This is inappropriate, I think: There's no do_entry_int82. With this
changed to a simply void entry_int82(void) declaration

Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx>

Jan


_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
https://lists.xen.org/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.