[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH] simplify xenmem_add_to_physmap_batch()

>>> On 06.12.17 at 17:40, <andrew.cooper3@xxxxxxxxxx> wrote:
> On 06/12/17 16:21, Jan Beulich wrote:
>> There's no need for
>> - advancing the handles and at the same time using
>>   __copy_{from,to}_guest_offset(),
>> - an "out" label,
>> - local variables "done" and (function scope) "rc".
>> Signed-off-by: Jan Beulich <jbeulich@xxxxxxxx>
> These changes do mean that start is no longer ideally named.  How about
> s/start/extent/, which also matches up better with the parameter name
> passed in by its caller?

I did think about it, but then decided that it's still the start of what
is yet to be done. But I can do the renaming if you indeed think
that's better; it'll only marginally increase page size afaict.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.