[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 1/6] x86/mm: Use mfn_eq()/mfn_add() rather than opencoded variations
>>> On 15.08.18 at 20:34, <andrew.cooper3@xxxxxxxxxx> wrote: > --- a/xen/arch/x86/mm/hap/hap.c > +++ b/xen/arch/x86/mm/hap/hap.c > @@ -729,7 +729,8 @@ hap_write_p2m_entry(struct domain *d, unsigned long gfn, > l1_pgentry_t *p, > * unless the only change is an increase in access rights. */ > mfn_t omfn = l1e_get_mfn(*p); > mfn_t nmfn = l1e_get_mfn(new); > - flush_nestedp2m = !( mfn_x(omfn) == mfn_x(nmfn) > + > + flush_nestedp2m = !(mfn_eq(omfn, nmfn) > && perms_strictly_increased(old_flags, l1e_get_flags(new)) ); Seeing that you strip the stray leading space, could you strip the stray trailing one as well, and move the && to its proper place? With the one previously pointed out issue fixed Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx> Jan _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |