[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 3/7] xen/hvm: Rename d->arch.hvm_domain to d->arch.hvm
On Tue, Aug 28, 2018 at 06:39:02PM +0100, Andrew Cooper wrote: > The trailing _domain suffix is redundant, but adds to code volume. Drop it. > > Reflow lines as appropriate, and switch to using the new XFREE/etc wrappers > where applicable. > > No functional change. > > Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> Reviewed-by: Wei Liu <wei.liu2@xxxxxxxxxx> > diff --git a/xen/arch/x86/domain.c b/xen/arch/x86/domain.c > index 4cdcd5d..3dcd7f9 100644 > --- a/xen/arch/x86/domain.c > +++ b/xen/arch/x86/domain.c > @@ -505,7 +505,7 @@ int arch_domain_create(struct domain *d, > > /* Need to determine if HAP is enabled before initialising paging */ > if ( is_hvm_domain(d) ) > - d->arch.hvm_domain.hap_enabled = > + d->arch.hvm.hap_enabled = > hvm_hap_supported() && (config->flags & XEN_DOMCTL_CDF_hap); > > if ( (rc = paging_domain_init(d, config->flags)) != 0 ) > diff --git a/xen/arch/x86/domctl.c b/xen/arch/x86/domctl.c > index fdbcce0..f306614 100644 > --- a/xen/arch/x86/domctl.c > +++ b/xen/arch/x86/domctl.c > @@ -745,7 +745,7 @@ long arch_do_domctl( > unsigned int fmp = domctl->u.ioport_mapping.first_mport; > unsigned int np = domctl->u.ioport_mapping.nr_ports; > unsigned int add = domctl->u.ioport_mapping.add_mapping; > - struct hvm_domain *hvm_domain; > + struct hvm_domain *hvm; Yet I think this hvm is clearer if it stays hvm_domain. I don't feel too strong for this though. Wei. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |