[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2 2/2] x86/pv: Code improvements to do_update_descriptor()

 >>> On 10.12.18 at 15:06, <andrew.cooper3@xxxxxxxxxx> wrote:
> * Add "uint64_t raw" to seg_desc_t to remove the opencoded uint64_t casting
>    in this function.  Change the parameter to be of type seg_desc_t.
>  * Rename the 'pa' parameter to 'gaddr', because it lives in GFN space rather
>    than physical address space.
>  * Use gfn_t and mfn_t rather than unsigned longs.
>  * Check the alignment and proposed new descriptor before taking a page
>    reference.
>  * Reuse the out label for all exit paths.
>  * Use the more flexible ACCESS_ONCE() accessor in preference to
>    write_atomic()
> No expected change in behaviour.
> Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>
> Reviewed-by: Wei Liu <wei.liu2@xxxxxxxxxx>

Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx>

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.