[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 2/2] x86emul: slightly alter AVX512 exception checking conditionals

>>> On 10.12.18 at 15:00, <andrew.cooper3@xxxxxxxxxx> wrote:
> On 07/12/2018 11:18, Jan Beulich wrote:
>> While actually benign (operands are either register or memory ones
>> anyway), I think it is better to use != instead of == for such checks.
>> Signed-off-by: Jan Beulich <jbeulich@xxxxxxxx>
> I don't see the point of making this change.  Code is easier to follow
> when there are fewer negations.

Is != a negation? I ask because in general I agree with that position
of yours. The idea here is that besides OP_REG and OP_MEM we
also have OP_IMM and OP_NONE. By carefully using != and == I'm
trying to make sure (and not the least document) that (in the cases
here) we don't let things go through in case the value (mistakenly)
is one of the "impossible" (in these contexts) two.

> But whatever - Acked-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>



Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.