[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 04/60] xen/sched: use new sched_unit instead of vcpu in scheduler interfaces
On 18.07.19 19:44, Dario Faggioli wrote: On Tue, 2019-05-28 at 12:32 +0200, Juergen Gross wrote:In order to prepare core- and socket-scheduling use a new struct sched_unit instead of struct vcpu for interfaces of the different schedulers. Rename the per-scheduler functions insert_vcpu and remove_vcpu to insert_unit and remove_unit to reflect the change of the parameter. In the schedulers rename local functions switched to sched_unit, too. For now this new struct will contain a vcpu pointer only and is allocated on the stack. This will be changed later. Signed-off-by: Juergen Gross <jgross@xxxxxxxx>This looks good to me. One thing that came to mind, is that the various function parameters and local variables called 'unit', could be called 'su'. It's a contraction of 'sched_unit', like, e.g., 'v' or 'vc' were contractions of 'vcpu', it's still quite descriptive, it's short, which is always good, IMO, and might mean less line wrap reformatting (considering that it's replacing 'v' or 'vc'). Of course, this will likely mean changing all the other ~60 patches, so I'll understand if you say that it would be too much. I prefer "unit", as it is more readable and the effort to do the change would be quite large (replacing "item" by "unit" was doable via sed, while this change would require more manual intervention). Also...index 2201faca6b..72a17758a1 100644 --- a/xen/include/xen/sched.h +++ b/xen/include/xen/sched.h @@ -275,6 +275,10 @@ struct vcpu struct arch_vcpu arch; };+struct sched_unit {+ struct vcpu *vcpu; +}; +Is my understanding correct that this field is going to be renamed vcpu_list, right from this patch? Yes. Juergen _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |