[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH 4/7] xen/arm: mm: Add more ASSERT() in {destroy, modify}_xen_mappings()
Hi Julien, On 24.06.2022 11:11, Julien Grall wrote: > From: Julien Grall <jgrall@xxxxxxxxxx> > > Both destroy_xen_mappings() and modify_xen_mappings() will take in > parameter a range [start, end[. Both end should be page aligned. > > Add extra ASSERT() to ensure start and end are page aligned. Take the > opportunity to rename 'v' to 's' to be consistent with the other helper. > > Signed-off-by: Julien Grall <jgrall@xxxxxxxxxx> > --- > xen/arch/arm/mm.c | 10 +++++++--- > 1 file changed, 7 insertions(+), 3 deletions(-) > > diff --git a/xen/arch/arm/mm.c b/xen/arch/arm/mm.c > index 0607c65f95cd..20733afebce4 100644 > --- a/xen/arch/arm/mm.c > +++ b/xen/arch/arm/mm.c > @@ -1371,14 +1371,18 @@ int populate_pt_range(unsigned long virt, unsigned > long nr_mfns) > return xen_pt_update(virt, INVALID_MFN, nr_mfns, _PAGE_POPULATE); > } > > -int destroy_xen_mappings(unsigned long v, unsigned long e) > +int destroy_xen_mappings(unsigned long s, unsigned long e) I think the prototype wants to be updated as well in include/xen/mm.h. x86 mm.c already uses s instead of v so it is a good opportunity to fix the prototype. Cheers, Michal
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |