[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 2/3] x86: Introduce new debug.c for debug register infrastructure
- To: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>
- From: Jan Beulich <jbeulich@xxxxxxxx>
- Date: Tue, 29 Aug 2023 16:10:49 +0200
- Arc-authentication-results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=suse.com; dmarc=pass action=none header.from=suse.com; dkim=pass header.d=suse.com; arc=none
- Arc-message-signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=ggFts29RRNVx8UBKPrptteloWQrKbmViEBmj/ZzO1XA=; b=jZUwUQ8JqCmhFtZ+PFEz8uHIeA2xgHD2uJh6/JFTiOp/PYChzG5lRueeZy73qCCGSL8U5uJ7l3gzP2WN5T7VhHTWgz8vPkQgRb2156nkk5DbPwrIiiCShsWjLUwFH28JaXO7qSa2SvjxRi6pxEn3VlbrUV29L+aY1cvEPq2TicQEHxXdo3Y0KYDUb9VmuIxZerfomsVZBx3PX/dQNy9sGmOMO72WKR+6wjUimah1wa78mjdJsuuqaAi89+iOAi1OFJSE3bf/jGrV52uVKw8F0ti6QwfzgUit5rnuWeR4ppb1PE0syRSPiNhREhzEVPPf/mSptRkWKFkhknQ5aPaA6A==
- Arc-seal: i=1; a=rsa-sha256; s=arcselector9901; d=microsoft.com; cv=none; b=DZM5pZWvl/o453NAe0XtaFWVs2ulmpz75m4PfvoKYzDZspl4bu1aoPc24bCRwNKywCZeL+BUGBoT+lRoRfbopuCaF8TV/Ju5Ejm0YHT7O8rAUw7swYeFhxtk5+BRlCrbpbKZ2TO61+A9XbiHYvw4mf+m0zk5vn5WLqdCLJ7n83fRKxxBNq5Y4NduGEXbUcDmUThztUy2fBdvr9hXh/ZGpcHO8u/xXRZcFHuwASYK23uIqysSo/zrZsoWnQmEK1LNVCnqCgIjTXuDaAbx/zOrZ0XxYPfDzhFOz3/nR9b403xLa4Wcl4B/eoe1lUn1BETOTGXzRcq8PVrrsckudCc/tA==
- Authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=suse.com;
- Cc: Roger Pau Monné <roger.pau@xxxxxxxxxx>, Wei Liu <wl@xxxxxxx>, Jinoh Kang <jinoh.kang.kr@xxxxxxxxx>, Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxxx>
- Delivery-date: Tue, 29 Aug 2023 14:11:08 +0000
- List-id: Xen developer discussion <xen-devel.lists.xenproject.org>
On 29.08.2023 15:43, Andrew Cooper wrote:
> Broken out of the subsequent patch for clarity.
>
> Add stub x86_adj_dr{6,7}_rsvd() functions which will be extended in the
> following patch to fix bugs, and adjust debugreg.h to compile with a more
> minimal set of includes.
>
> Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>
Acked-by: Jan Beulich <jbeulich@xxxxxxxx>
preferably with (nit) ...
> --- a/xen/arch/x86/include/asm/debugreg.h
> +++ b/xen/arch/x86/include/asm/debugreg.h
> @@ -77,7 +77,18 @@
> asm volatile ( "mov %%db" #reg ",%0" : "=r" (__val) ); \
> __val; \
> })
> +
> +struct vcpu;
> long set_debugreg(struct vcpu *, unsigned int reg, unsigned long value);
> void activate_debugregs(const struct vcpu *);
>
> +struct cpu_policy;
> +
> +/*
> + * Architecturally dr6/7 are full GPR-width, but only the bottom 32 bits may
> + * legally be non-zero. We avoid avoid storing the upper bits when possible.
... one "avoid" dropped here.
Jan
|