[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH v11 05/17] vpci: add hooks for PCI device assign/de-assign
On Sat, Dec 02, 2023 at 01:27:03AM +0000, Volodymyr Babchuk wrote: > From: Oleksandr Andrushchenko <oleksandr_andrushchenko@xxxxxxxx> > > When a PCI device gets assigned/de-assigned we need to > initialize/de-initialize vPCI state for the device. > > Also, rename vpci_add_handlers() to vpci_assign_device() and > vpci_remove_device() to vpci_deassign_device() to better reflect role > of the functions. > > Signed-off-by: Oleksandr Andrushchenko <oleksandr_andrushchenko@xxxxxxxx> > Signed-off-by: Volodymyr Babchuk <volodymyr_babchuk@xxxxxxxx> Reviewed-by: Roger Pau Monné <roger.pau@xxxxxxxxxx> > diff --git a/xen/include/xen/vpci.h b/xen/include/xen/vpci.h > index d743d96a10..75cfb532ee 100644 > --- a/xen/include/xen/vpci.h > +++ b/xen/include/xen/vpci.h > @@ -25,11 +25,11 @@ typedef int vpci_register_init_t(struct pci_dev *dev); > static vpci_register_init_t *const x##_entry \ > __used_section(".data.vpci." p) = x > > -/* Add vPCI handlers to device. */ > -int __must_check vpci_add_handlers(struct pci_dev *pdev); > +/* Assign vPCI to device by adding handlers to device. */ Nit: the comment would likely benefit from removing the last device before the full stop. > +int __must_check vpci_assign_device(struct pci_dev *pdev); Thanks, Roger.
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |