[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] [Fwd: Re: [Xen-devel] Run X in other domains?]

Hi Gerd,

Thanks for the response and your tips.

On Tue, 2005-04-19 at 11:07 +0200, Gerd Knorr wrote:
> Sean Atkinson <sean@xxxxxxxxxxxxxx> writes:
> > The output from lspci lists everything but the VGA card in domain 0,
> > unless "lspci -H 1" is used.  In other domains, lspci reports only the
> > VGA card and "lspci -H 1" reports "You need to be root to have access to
> > I/O ports".  However X still starts OK in domain 0, which surprised my.
> X wants bang directly on the Hardware.  Try "X -scanpci" in domain 0,
> most likely you'll see the hidden gfx card listed there.

"X -scanpci" silently exits in every environment I tried, except in
domain 1 where it fails with "xf86EnableIOPorts: Failed to set IOPL for
I/O".  Perhaps I'm missing something?

> > Does anybody have any experience with X in other domains, or thoughts on
> > how I might proceed please?
> I tried the same some time ago in user mode linux (tried to make X11
> run on top of a virtual framebuffer device) and ran into simliar
> issues.  It simply didn't work without hacking the X-Server.  X11 was
> very unhappy about not being able to access hardware directly, even
> though there was absolutely no need to do that.  I wanted it simply
> open and use the /dev/fb0 device ...

Oh dear - this doesn't sound too encouraging ... :o(

> X.org has several ways of accessing the PCI bus, you can play with
> that using the "scanpci" utility.  "OS config" (-O switch for scanpci)
> should in theory use /proc/bus/pci, work fine without direct hardware
> access enabled and list the gfx card in the domain you've assigned it
> to.  In practice it doesn't, scanpci refuses to work without iopl
> access and also doesn't use /proc/bus/pci due to a bug.  It should
> have improved in x.org tree, cvs HEAD, because I bugged the suse x.org
> guy to look into this because of the uml issues mentioned above.
> Havn't tested that recently though.

In domain 0 with my graphics card hidden, passing "-O" to the scanpci
binary or "-H 1" to lspci adds 3 devices to the output - the VGA card,
AGP bridge and a SMBus device.  In domain 1 both binaries fail reporting
I/O port problems.

Guess I'll have to wait to try these upcoming X fixes ...



Sean Atkinson <sean@xxxxxxxxxxxxxx>

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.