[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xen, tls, futex locks and berkley db

I ran into a problem which I don't know how to solve.
In order for xen to run in maximum performance, tls should be disabled. However on that machine I want to run openldap with berkley db backend. When openldap is started; I get the following error:

bdb_db_open: dbenv_open failed: Function not implemented (38)
slapd[8218]: backend_startup: bi_db_open(0) failed! (38)
slapd[8218]: bdb(dc=eccent,dc=be): DB_ENV->lock_id_free interface requires an environment configured for the locking subsystem
slapd[8218]: bdb(dc=eccent,dc=be): txn_checkpoint interface requires an environment configured for the transaction subsystem
slapd[8218]: bdb_db_destroy: txn_checkpoint failed: Invalid argument (22)

On one mailing list (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=152939) I found it related to :
"This is actually what glibc prints when you try to use futex locks without tls/nptl libc, iirc."

So enabled tls again, rebooted and tadaaa ... now it works.

How should I solve this? what is the status on tls support? I'm currently running 2.0-testing.
Maybe this is not the right place to ask this question, but: can I compile berkley db (and/or other software) without the need for tls/nptl support?

Thanx in advance for any pointer in the right direction.


Filip Sergeys

* System Engineer, Verzekeringen NV *
* www.verzekeringen.be              *
* Oostkaai 23 B-2170 Merksem        *
* 03/6416673 - 0477/340942          *
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.