[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xm save while VM is writing once per second?

On Tue, 2005-05-10 at 15:04 -0400, Jeff Blaine wrote:
> I must not be understanding something trivial that I cannot
> find in the documentation.
> I am running Xen 2.0.5 with Fedora Core 3 successfully.
> I have a VM (VM4) running a test shell script that loops
> infinitely while writing the date and a counter every
> second (to /tmp/counter).
> The entire VM is using a file-backed VBD for all storage
> (/vm-images/vm-4-disk acting as sda1 to the VM).
> Running 'xm save VM4 /vm-images/vm4.save' from dom0
> never returns (well, I have been staring at it for 5
> minutes now).
> 'xm save VM4 /vm-images/vm4.save' works fine without the
> looping script writing to /tmp/counter every second.
> Somebody clue me in?

This may sound odd, but have you run the save command a second time
after the first time never returned? I have a similar configuration as
you and I just ran xm save command. The first time, it just sat there
and didn't return. I exited it and ran the command again and it worked. 

I'm still figuring out why. But it worked the second time I ran the xm
save command.

I followed up the save with "xm restore" and that worked.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.