[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] cannot boot any domU


I am new to xen. I have been able to boot the dom0 but not any
domU or guest operating systems. Here is my story. I apologize
it is long but wanted to provide details. I appreciate any
assistance I that might be provided.

The machine is a single-CPU Pentium 4 with 1 GB of RAM and 3
hard drives installed. It is fairly vanilla hardware (detail
available if needed).

The base OS is/was Fedora Core 3. It is installed with / on
/dev/hda1 and linux swap on /dev/hda2. By default it boots
into runlevel 3 (no X).

I began by installing the Linux bridge-utils and then
ZopeInterface 3.0.1 and then Twisted 2.0.1 and TwistedWeb 0.5.
I had no problems.

Next I downloaded the binary tarball
xen-2.0.6-install-x86_32.tgz, unpacked it, and ran install.sh
with no problems.

I added the following lines to my grub.conf file:

title Xen 2.0 / XenLinux 2.6
        kernel /boot/xen-2.0.gz dom0_mem=131072
        module /boot/vmlinuz-2.6-xen0 root=/dev/hda1 ro console=tty0
        module /boot/initrd-2.6.12-1.1372_FC3-2.6-xen0

The ramdisk I made by first running "depmod"
and then 

mkinitrd /boot/initrd-2.6.12-1.1372_FC3-2.6-xen0 2.6-xen0

Next I moved the TLS libraries out of the way as instructed in the

I then rebooted and booted into the Xen kernel. It appears to
be fine:

[root@garlic ~]# uname -a
Linux garlic.phys.uwm.edu #1 Sun May 22
11:38:50 BST 2005 i686 i686 i386 GNU/Linux

I do not see anything particularly disturbing during boot
(only that sunrpc cannot be started).

Next I rebooted and used a Fedora Core 4 CD to install FC4. I
installed it with / on /dev/hdc1. During the install I chose
not to install a new GRUB and instead later edited the
existing grub.conf in the FC3 partition on /dev/hda1. I am
able to boot into the FC4 partition directly with no problem.

I copied the directory /lib/modules/ from the
FC3 partition on /dev/hda1 to the /lib/modules directory on
the FC4 partition on /dev/hdc1.

I next created a configuration file to try and boot FC4 as a
Xen domain. Here are the contents of the file:

kernel = "/boot/vmlinuz-2.6.11-xenU"
ramdisk = "/boot/initrd-2.6-xenU.img"
memory = 512
name = "FedoraCore4-01"
disk = [ 'phy:hdc1,hda1,w', 'phy:hda2,hda3,w']
root = "/dev/hda1 ro"
extra = "3"

I also edited /etc/fstab on the FC4 partition in /dev/hdc1 and
changed / to be mounted on hda1 (the virtual one I assume
provided by Xen) and swap to be mounted on hda3 (again the
virtual one).

With all this in place I then do

xend start
xm create -c /etc/xen/xmfc4

I see the output

Using config file "/etc/xen/xmfc4"

and then the hardware hangs immediately and completely...no response 
in dom0 from keyboard and the machine is no longer ping-able.

I also tried the example from the manual (ttylinux): I
downloaded ttylinux-xen.bz2, unzipped it, and created the
configuration file

kernel = "/boot/vmlinuz-2.6-xenU"
memory = 64
name = 'ttylinux'
nics = 1
ip = ''
disk = ['file:/root/ttylinux-xen,sda1,w']
root = '/dev/sda1 ro'

When I try to run

xend start
xm create -c /etc/xen/ttylinux

I get the same result--hardware hangs immediately and
completely with no keyboard and no network (not ping-able).

I have watched /var/log/messages while doing this but there is
nothing interesting written.

Again thanks for reading and I would appreciate any help you
can offer.


Scott Koranda

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.