[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Spam:*, [Xen-users] cannot boot any domU

Hi Scott,

I'm not sure if I can help, but I'll take a stab:

Scott Koranda wrote:

>I added the following lines to my grub.conf file:
>title Xen 2.0 / XenLinux 2.6
>        kernel /boot/xen-2.0.gz dom0_mem=131072
>        module /boot/vmlinuz-2.6-xen0 root=/dev/hda1 ro console=tty0
>        module /boot/initrd-2.6.12-1.1372_FC3-2.6-xen0
>The ramdisk I made by first running "depmod"
>and then 
>mkinitrd /boot/initrd-2.6.12-1.1372_FC3-2.6-xen0 2.6-xen0
>Next I rebooted and used a Fedora Core 4 CD to install FC4. I
>installed it with / on /dev/hdc1. During the install I chose
>not to install a new GRUB and instead later edited the
>existing grub.conf in the FC3 partition on /dev/hda1. I am
>able to boot into the FC4 partition directly with no problem.
>I copied the directory /lib/modules/ from the
>FC3 partition on /dev/hda1 to the /lib/modules directory on
>the FC4 partition on /dev/hdc1.
>I next created a configuration file to try and boot FC4 as a
>Xen domain. Here are the contents of the file:
>kernel = "/boot/vmlinuz-2.6.11-xenU"
>ramdisk = "/boot/initrd-2.6-xenU.img"
>memory = 512
>name = "FedoraCore4-01"
>disk = [ 'phy:hdc1,hda1,w', 'phy:hda2,hda3,w']
>root = "/dev/hda1 ro"
>extra = "3"
Perhaps take out anything that has a sane default.
eg. dhcp and ramdisk.

>I also edited /etc/fstab on the FC4 partition in /dev/hdc1 and
>changed / to be mounted on hda1 (the virtual one I assume
>provided by Xen) and swap to be mounted on hda3 (again the
>virtual one).
For debugging and sanity purposes it might be an idea to
leave your fstab alone (for the moment), and make the export line:

disk = [ 'phy:hdc1,hdc1,w', 'phy:hdc2,hdc2,w']

Then you will still be able to boot FC4 normally.

>With all this in place I then do
>xend start
>xm create -c /etc/xen/xmfc4
>I see the output
>Using config file "/etc/xen/xmfc4"
>and then the hardware hangs immediately and completely...no response 
>in dom0 from keyboard and the machine is no longer ping-able.
I'm interested in how 'immediate' this is as I suspect you have a
problem with your initrd. You might be able to see something with

xm create xmfc4 && xm console n

(You need to know what the next console number will be, of course!:))

>I also tried the example from the manual (ttylinux): I
>downloaded ttylinux-xen.bz2, unzipped it, and created the
>configuration file
>kernel = "/boot/vmlinuz-2.6-xenU"
>memory = 64
>name = 'ttylinux'
>nics = 1
>ip = ''
>disk = ['file:/root/ttylinux-xen,sda1,w']
>root = '/dev/sda1 ro'
>When I try to run
>xend start
>xm create -c /etc/xen/ttylinux
>I get the same result--hardware hangs immediately and
>completely with no keyboard and no network (not ping-able).
This shoots a hole in my initrd theory, but try chaining the console
command for any signs of output.

What options have you set in your dom0 and domU kernels?
What do your mkinitrd configs contain?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.