[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Spam:*, [Xen-users] cannot boot any domU

> Hi Scott,
> I'm not sure if I can help, but I'll take a stab:

Thanks much.

> >
> >kernel = "/boot/vmlinuz-2.6.11-xenU"
> >ramdisk = "/boot/initrd-2.6-xenU.img"
> >memory = 512
> >name = "FedoraCore4-01"
> >disk = [ 'phy:hdc1,hda1,w', 'phy:hda2,hda3,w']
> >dhcp="dhcp"
> >root = "/dev/hda1 ro"
> >extra = "3"
> >  
> >
> Perhaps take out anything that has a sane default.
> eg. dhcp and ramdisk.

Ok. I removed both.

> >I also edited /etc/fstab on the FC4 partition in /dev/hdc1 and
> >changed / to be mounted on hda1 (the virtual one I assume
> >provided by Xen) and swap to be mounted on hda3 (again the
> >virtual one).
> >  
> >
> For debugging and sanity purposes it might be an idea to
> leave your fstab alone (for the moment), and make the export line:
> disk = [ 'phy:hdc1,hdc1,w', 'phy:hdc2,hdc2,w']
> Then you will still be able to boot FC4 normally.

Good idea. Ok, I have done that.

I tried again both FC4 and ttylinux, but found the same
immediate hang...

> >With all this in place I then do
> >
> >xend start
> >xm create -c /etc/xen/xmfc4
> >
> >I see the output
> >
> >Using config file "/etc/xen/xmfc4"
> >
> >and then the hardware hangs immediately and completely...no response 
> >in dom0 from keyboard and the machine is no longer ping-able.
> >  
> >
> I'm interested in how 'immediate' this is as I suspect you have a
> problem with your initrd. 

As soon as I enter the command ' xm create -c /etc/xen/xmfc4 '
I see the single line

Using config file "/etc/xen/xmfc4".

and then nothing else. The keyboard does not respond from that
point on and the machine can no longer be pinged.

When I created the initrd for the dom0 domain (which seems to
boot fine) I did this:

mkinitrd /boot/initrd-2.6.12-1.1372_FC3-2.6-xen0

When I created the initrd for the domU domain I did this:

mkinitrd /boot/initrd-2.6-xenU

> You might be able to see something with
> xm create xmfc4 && xm console n
> (You need to know what the next console number will be, of course!:))
> >I also tried the example from the manual (ttylinux): I
> >downloaded ttylinux-xen.bz2, unzipped it, and created the
> >configuration file
> >
> >kernel = "/boot/vmlinuz-2.6-xenU"
> >memory = 64
> >name = 'ttylinux'
> >nics = 1
> >ip = ''
> >disk = ['file:/root/ttylinux-xen,sda1,w']
> >root = '/dev/sda1 ro'
> >
> >When I try to run
> >
> >xend start
> >xm create -c /etc/xen/ttylinux
> >
> >I get the same result--hardware hangs immediately and
> >completely with no keyboard and no network (not ping-able).
> >  
> >
> This shoots a hole in my initrd theory, but try chaining the console
> command for any signs of output.

I see the same single line of output and then the hardware

[root@garlic boot]# xm create /etc/xen/xmfc4 && xm console 1
Using config file "/etc/xen/xmfc4".

> What options have you set in your dom0 and domU kernels?

I am not exactly sure what you mean.

I am using the binary tarball xen-2.0.6-install-x86_32.tgz.
Neither the dom0 or domU kernels are kernels that I compiled

My grub.conf looks like this:

title Xen 2.0 / XenLinux 2.6
        kernel /boot/xen-2.0.gz dom0_mem=131072
        module /boot/vmlinuz-2.6-xen0 root=/dev/hda1 ro console=tty0
        module /boot/initrd-2.6.12-1.1372_FC3-2.6-xen0

I took this from section 2.4.1 of the manual, so I guess I am
passing the options dom0_mem=131072 and console=tty0 to dom0.
When I try to start a domU I am using the configuration file I
posted previously.

> What do your mkinitrd configs contain?

Sorry, I am not sure what you mean. The mkinitrd commands I
ran are the ones above. Other then that I can show you

[root@garlic boot]# cat /etc/modprobe.conf
alias eth0 8139too
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install
snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1
|| : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.