[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] cannot boot any domU

> Hi,
> On Thursday 04 August 2005 22:05, Scott Koranda wrote:
> > I next created a configuration file to try and boot FC4 as a
> > Xen domain. Here are the contents of the file:
> >
> > kernel = "/boot/vmlinuz-2.6.11-xenU"
> > ramdisk = "/boot/initrd-2.6-xenU.img"
> > memory = 512
> > name = "FedoraCore4-01"
> > disk = [ 'phy:hdc1,hda1,w', 'phy:hda2,hda3,w']
> most likely not the reason for the crash, but hda2 is your dom0's swap 
> partition? 


> using the same swap partition twice for the domU won't work..

Ok, good to know. Thanks.

> disk = [ 'phy:/dev/hdc1,hda1,w', 'phy:/dev/hdc2,hda3,w']
> is probably what you want (if you have unused swapspace in hdc2 and have set 
> up domU to swap on /dev/hda3)

I do have /dev/hdc2 set up as additional swap, so I made the
edit and tried again. Unfortunately it did not help (though it
sounds like it wasn't really expected to help with the crash).

Just to be pedantic I also tried configuring with no swap
visible, ie.

disk = [ 'phy:/dev/hdc1,hda1,w']

but as probably expected that did not help.

I expect the problem is that I am doing something so dumb it
is not easy to see...



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.