[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] help boot ing xen

Jacek Aviles wrote:
> module        /boot/vmlinux-2.6-xen0 root=/dev/sda4 ro console=tty1

This is (obviously) pointing to the wrong root filesystem. You must
point to the right one, or the kernel won't boot.

> Root-NFS: No NFS server available, giving up.
> VFS: Unable to mount root fs via NFS, trying floopy.

The Xen kernels are built by default with NFS-root support, and it will
kick in as a fallthrough if a conventional block device as the root
filesystem can't be found. The kernel's just trying all its options
before throwing up its hands.

> Then I tried “module  /boot/vmlinux-2.6-xen0 root=/dev/hda2 ro
> console=tty0”.  This is where my root partition is.  But I get the error:
> Kernel panic -  not syncing: VFS: unable to mount root fs on
> unknown-block(3,4)

Major 3, minor 4 is /dev/hda4. It seems rather odd and unlikely that
your kernel would start magically misparsing the root= argument. (If it
was doing that, I'd be amazed if it would run anything at all, because
the CPU would most likely be hosed entirely.)

> I then tried all possible permutation with the devices hdaX and sdaX and
> console=tty0, tty1, ttyS0.  I’m not too solid on what these different
> things mean.

You should probably learn. Google, and/or read relevant files in the
Documentation/ subdirectory of your kernel source tree.

> Finally when I do “module     /boot/vmlinux-2.6-xen0 root=/dev/hda1 ro
> console=tty0”, I get:
> Warning: unable to open an initial console.

There's no /dev/console, but it's apparently still trying. I know some
people load the packaged kernel's initrd as a workaround for this, since
the root filesystem itself on newer RPM-based distros that use udev
actually contains no device nodes at all.

> ///////////////////////////////
> //WARNING: Currently emulating unsupported memory accesses //in /lib/tls
> libraries.  The emulation is very slow.  To //ensure full performance
> you should execute the following //as root: mv /lib/tls /lib/tls.disabled
> ///////////////////////////////

Okay, this is normal.

> This is strange because I already renamed this item.  I did a  ‘Whereis’
> and a ‘Find’, and found another copy of it in /usr/bin and renamed that.
>  When the error message continued, I just deleted them out of
> desperation and I still get the same error.  Does anyone know what might
> be cause this error even though TLS was removed?  Thank you.

Depends on the distribution you're using. You didn't mention which one.
I know FC4 has no /lib/tls, because the libraries in /lib are the
TLS/NPTL enabled ones. I know it's something RPM-based, and recent (uses

Did it ever reach a login: prompt?

Derrik Pates

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.