[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] help boot ing xen

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Gino LV. Ledesma" <gledesma@xxxxxxxxx>
  • Date: Tue, 16 Aug 2005 09:04:56 -0700
  • Delivery-date: Tue, 16 Aug 2005 16:03:11 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=QG1cZiNzLWJXWx1Ns+92r07wiBXbrVtvjGXZZBJ0YFb6A/h5DDFFBIhEBgJSt8Y6XIux+2odHQes10ViaLd56WPURKpEHI3x5z+1sxYjlaJ45jWofV+w+lIU1/H0422qyavDhRvXZ7s767oMXdqJOZoW3Xigr2hUlQ4WRHRWvrk=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I've ran into this a lot of times in the past so I've more or less
gotten the hang of getting it to work. Try creating an initrd for your
kernel by first booting with your regular kernel and then:

mkinitrd /boot/initrd-<kernel_version>-xen0.img <kernel_version>-xen0

modify /etc/grub.conf and add:

module /boot/initrd-<kernel_version>-xen0.img to the xen boot options

Then try rebooting again. Most likely even though you've compiled
everything into the kernel /dev is empty and you see nothing past the
WARNING: /lib/tls message. In more recent RH-based distributions (not
sure about others), /dev is populated by udev on boot. If all else
fails, you can always MAKEDEV console null zero to make those

- gino ledesma

On 8/15/05, Jacek Aviles <ja754@xxxxxxx> wrote:
> Hi,
> I'm still having trouble rooting xen.  I've tried all kinds of different
> boot parameters and I got all kinds of different errors.  When I trying
> the setting given in the user manual:
> title           xen
> kernel          /boot/xen-2.0.gz dom0_mem=131072
> module  /boot/vmlinux-2.6-xen0 root=/dev/sda4 ro console=tty1
> I get the following error:
> Root-NFS: No NFS server available, giving up.
> VFS: Unable to mount root fs via NFS, trying floopy.
> Someone on the mailing list said this was cause because the system can't
> find the root fs.
> Then I tried "module    /boot/vmlinux-2.6-xen0 root=/dev/hda2 ro
> console=tty0".  This is where my root partition is.  But I get the error:
> Kernel panic -  not syncing: VFS: unable to mount root fs on
> unknown-block(3,4)
> I then tried all possible permutation with the devices hdaX and sdaX and
> console=tty0, tty1, ttyS0.  I'm not too solid on what these different
> things mean.
> Finally when I do "module       /boot/vmlinux-2.6-xen0 root=/dev/hda1 ro
> console=tty0", I get:
> Warning: unable to open an initial console.
> ///////////////////////////////
> //WARNING: Currently emulating unsupported memory accesses //in /lib/tls
> libraries.  The emulation is very slow.  To //ensure full performance
> you should execute the following //as root: mv /lib/tls /lib/tls.disabled
> ///////////////////////////////
> This is strange because I already renamed this item.  I did a  'Whereis'
> and a 'Find', and found another copy of it in /usr/bin and renamed that.
>  When the error message continued, I just deleted them out of
> desperation and I still get the same error.  Does anyone know what might
> be cause this error even though TLS was removed?  Thank you.
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.