[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] kernel panic - VFS: Unable to mount root fs on unknown-block(0, 0) -- xen IDE drivers?

I'm trying to install xen-2.0.7-src.tgz from a debian-sarge netinst-cd virgin install with one partition (/).  I'm following the instructions on http://www.option-c.com/xwiki/Custom_Xen_Kernels

The netinst-cd installs a 2.6.8 kernel. I'm using its config file and turning on XeN requirements for domain 0. The kernel builds and installs just fine. My grub entry looks like this:
title Debian-sarge 2.6.11 / XeN 2.0.7 (hda9)
root (hd0,8)
kernel /boot/xen.gz dom0_mem=393216 noreboot
module /boot/vmlinuz- root=/dev/hda9 ro console=tty0

It does not matter what I put in the root= line, I always get the same message. I think the key is block(0,0). I have no idea why it should say that at all.

(BTW, I've tried at least a half-dozen ways to get XeN installed on this system -- that is why I'm up to hda9. I've tried to get as simple an install as possible.)

Here's the bit that I'm a bit nervous about:
My motherboard actually has 2 PATA IDE controllers and 1 SATA controller. Initially it took me forever just to get debian to install at all because the BIOS saw all the controllers, but the debian CD only saw one -- and not the first one at that. I finally resolved that with BIOS and never turned on those drivers in any of the kernels I built including the XeN ones. I am suspicious though that the XeN kernel is somehow picking my other controllers up though -- not sure how though given I thought it used domain 0's drivers.

The other annoying thing is that debian-stable comes with 2.6.8 with devfs on. And although I gave up using mkinitrd with XeN (as I was trying to eliminate possible issues), debian-sarge insists on using devfs even in 2.6.11 if one intendes to use mkinitrd. I image this might be a problem at least for the domN kernels? I'm not there yet -- just pointing out things I'm seeing. My problem above happens with and without devfs compiled into the kernel.

BTW, The democd (2.0.6) works just great in this computer. But I can't figure out how to get that to my computer either.

I've seen a few other people complaining of similar issues to mine on the lists, but I haven't seen any answers that worked for me.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.