[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] mysql

Steven Yelton wrote:

I just installed the latest mysql packages on a non xen server and had the same problem. I copied the start script from another installation and it worked. (A diff showed no differences, a co-worker told me the script was haunted). Can you run 'mysqld_safe' from the command line successfully?

Here is my init.d script that worked:

"Haunted script" ? :))
I don't know what your environment is, but if You're using RHEL4, FC3,
CentOS, or something newer, the bundled MySQL (or to be specific :
MySQL's BDB engine) requires glibc to have NPTL support. Removing
/lib/tls effectively disables NPTL, which results in MySQL failed to start.

You can work around this problem by adding "skip-bdb" to your
/etc/my.cnf, or /var/lib/mysql/my.cnf, or any other config file and
startup script that MySQL reads during startup.

A better solution, in my oppinion, is to use Xen-specific glibc
<http://wiki.xensource.com/xenwiki/XenSpecificGlibc>. This will solve
MySQL, DB4, and other problems caused by NPTL glibc.



Mark Olliver wrote:


Just want to do a quick check before I spend hours debugging a problem. I have xen running and on the virtual server I have just installed the latest rpm from Centos (the guest and main os) from mysqld. When I went to start it, it fall over and give no error.

Any ideas, do I need to do anything extra for the xen platform, I presume not


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.