[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Problem in migration (xen-unstable)

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Mark Ryden <markryde@xxxxxxxxx>
  • Date: Thu, 10 Nov 2005 11:44:27 +0200
  • Delivery-date: Thu, 10 Nov 2005 09:44:40 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=epLgTFRGwCjgv+jB3Z86ju/r560UMjU2lTba/U+72XiYEee/r/W18U2oJ9WlJEHL6M/Yw0wc+r9j6Dfef8jk19Lg0mUmJkvkmOScY+a8UcoHXjxDSzfA2npn20nwW0LmT/IndRMSNkmE1e/e6Jkw73+L4qlFTNZnIfL6mEiZ4Pk=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


I am trying to migrate domainU from machine A to machine B.
On both machines there is xen-unstable from this week.

The migration fails, and this is the error I get:
Error: can't connect: Connection refused

More details:
I am trying to migrate a domain from machine A to machine B.

On machine A , on which I issue the "xm migrate" command,
xm list shows:

Name                              ID Mem(MiB) VCPUs State  Time(s)
Domain-0                           0       58     1 r-----   137.1
katz                               3       19     1 -b----    65.9

and the command I issue is:
 xm migrate 3
 where is on the same subnet as I am and runs
 also Xen. (both machines are on the same hub and of course I verified
 that there is a ping between them).

ifconfig shows the following interfaces on machine A:

the vif* interfaces do not have an IP address in them ; the eth0 of
course has the right IP address (maybe
this is the problem ? in such a case , what **exactly**
should I do to set the vif*  addresses and which of them should
I set (or all)? )

For example
(vif0.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          RX packets:2712 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11376 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:517584 (505.4 KiB)  TX bytes:1371081 (1.3 MiB)

xen-unstabel version:
hg tip on machine A shows:
changeset:   7701:abbe3df33774
date:        Tue Nov  8 19:39:58 2005 +0100

I want to add tha saving adomain DOES work: tried : xm save 3
/work/domain3.save and it finished it's worked
with no errors and created the saced domain file.

Any ideas?

Mark R.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.