[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

FW: FW: [Xen-users] Xen and OpenSSI

  • To: <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Owen Campbell" <owen@xxxxxxxxxxxxx>
  • Date: Fri, 17 Feb 2006 09:11:56 -0000
  • Delivery-date: Fri, 17 Feb 2006 10:35:19 +0000
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcYzGqIdsazs/5hHRBmJ9POGD1bR4QAhz5sw
  • Thread-topic: FW: [Xen-users] Xen and OpenSSI

Almost there!!!!

I've now got the domU to boot (by copying in the modules for
2.6.11-ocxenu as suggested).

My problem now is creating the initrd to add new nodes to the cluster.
Because I downloaded the openssi kernel (which is based on 2.6.10), I
don't have the associated modules and the mkinitrd fails.

Is there anywhere I can get them?


-----Original Message-----
From: N Clements [mailto:optionc.ltd@xxxxxxxxx] 
Sent: 16 February 2006 17:01
To: Owen Campbell
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: FW: [Xen-users] Xen and OpenSSI

You need to make sure you've got the appropriate modules inside the
domU. Look in the /lib/modules directory. If there's nothing in there
then you'll need to copy them from the dom0. Either shut down the
domU, mount the image/device with the root vbd and copy them across,
or scp/ftp  them in.

For example (from the dom0, assuming the domU is not running):
# mkdir /mnt/domU
# mount -o loop /images/domU.img /mnt/domU
# cp -dpR /lib/modules/2.6.11-ocxenu /mnt/domU/lib/modules
# umount /mnt/domU

Reboot your domU. Then try the modprobe function again.

After that mkinitrd ought to work.

On 2/16/06, Owen Campbell <owen@xxxxxxxxxxxxx> wrote:
> Ok, I tried from scratch again and here's where I got to.....
> When I run 'mkinitrd -o /tmp/initrd', I get
> cpio: initrd/lib/libc.so.6 not created: newer or same age version
> cpio: initrd/lib/libcluster.so.0 not created: newer or same age
> exists
> 4584+0 records in
> 4584+0 records out
> 4694016 bytes transferred in 0.291641 seconds (16095183 bytes/sec) All
> of your loopback devices are in use!
> And initrd is created in the /tmp directory
> If I run 'modprobe loop' I get
> modprobe: Can't open dependencies file
> /lib/modules/2.6.11-ocxenu/modules.dep (No such file or directory)
> So it looks like you were all correct and the problem is initrd
> creation!!!
> I'm afraid I've always avoided kernel building, so this is all a bit
> to me. Any ideas how I get the initrd created?
> Owen

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.