[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Ctrl+C does not work in virtual console

Hi all,

I have a problem with the virtual console. I run Xen 3.0.1 (compiled from the sources) on debian 3.1 (as dom0 and domU) on an AMD Athlon 64.

I can't terminate programs with ctrl+c. If I try for example to ping a machine, ping runs forever and cannot be stopped from the console. ctrl+z does then not work either. But if I do the same with ssh, everything works fine. There are more commands which cannot be controlled with ctrl+c and ctrl+z, like lynx and 'more'.

What confuses me, is that for example I can exit emacs using "ctrl+x ctrl+c" without problems (in the virtual console). If I run ping in a shell in emacs, I can stop the process pressing ctrl+c twice (as expected). Emacs also is put in background if I press ctrl+z.

When you type something on the shell (without enter) and press ctrl+c, usually the line is aborted and a new empty one is started. In my virtual console this is not the case.

I hope someone of you can give me a hint what causes this strange behavior. It's impossible to work with the virtual console, because if one tries to check network connections, the session is over.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.