[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] e100 + Xen + VLAN -> VLANs don't work?

Javier Guerra wrote:
On Friday 02 February 2007, Tomasz Chmielewski wrote:
Any clues on why VLANs don't work anymore with Intel Ethernet Pro 100
card when I start the "network-bridge" script?

for VLANs it's very convenient to use an MTU of 1504 on the ethx device (and 1500 on the vlanxx devices). but most 100mbit drivers don't allow any MTU of more than 1500 (even if the cards themselves usually allow at least 1600). all Gb drivers i know allow for MTUs up to 9000

but i don't know if your scripts try to setup the MTU to 1504... might be something else

Yes, these 100 Mbit cards don't support MTU higher than 1500 (I have this issue with Intel/e100 and Realtek/8139too cards; with 1 Gbit cards everything works flawlessly).

So I tried to setup VLANs (eth0.xxx) MTU to 1496, then to 1450, and it made no difference - still doesn't work.

Tomasz Chmielewski

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.