[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Unable to boot guest

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Brad King <brad@xxxxxxxxxx>
  • Date: Mon, 19 Feb 2007 23:28:30 +1100 (EST)
  • Delivery-date: Mon, 19 Feb 2007 04:50:39 -0800
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi All,

I have just installed xen on fedora core 5. I used yum to install xen and 
kernel-xen0 (and their dependancies)

I can reboot into the new domain0 without issue. When I try and configure a new 
domain using xenguest-install.py it gets to the point of wanting to install, 
and then fails.

I have mounted the Fedora Core 5 DVD on /var/www/html/fc5 and the webserver is 
running, and it is also exported via NFS (So I could test multiple methods)
Neither work. Below are the steps taken and the resulting output:

[root@xen01 xen]# xenguest-install.py
What is the name of your virtual machine? fc5
How much RAM should be allocated (in megabytes)? 256
What would you like to use as the disk (path)? /opt/xen/vmdisk/fc5
How large would you like the disk to be (in gigabytes)? 4
What is the install location? http://localhost/fc5

Starting install...
libvir: Xen Daemon error : POST operation failed: (xend.err 'destroyDevice() 
takes exactly 3 arguments (2 given)')
Failed to get devices for domain fc5
Traceback (most recent call last):
File "/usr/sbin/xenguest-install.py", line 460, in ?
File "/usr/sbin/xenguest-install.py", line 451, in main
start_paravirt_install(name, ram, disk, mac, uuid, src, options.extra)
File "/usr/sbin/xenguest-install.py", line 331, in start_paravirt_install
dom = conn.createLinux(cfgxml, 0)
File "/usr/lib/python2.4/site-packages/libvirt.py", line 249, in createLinux
if ret is None:raise libvirtError('virDomainCreateLinux() failed')
libvirt.libvirtError: virDomainCreateLinux() failed

I tried to free up some memory for the new Virtual machine but this did not 
help either.
[root@xen01 xen]# xm list
Name ID Mem(MiB) VCPUs State Time(s)
Domain-0 0 512 1 r----- 146.9

I also tried using NFS and got the same results.

Any ideas where to look for this problem?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.