[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Guest-domain has no login

  • From: Frank Morane <info@xxxxxxxx>
  • Date: Sat, 30 Jun 2007 12:28:54 -0600
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Mon, 02 Jul 2007 09:36:30 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

trilok nuwal wrote:
U have to add this line to /etc/inittab of guest to get the console up.
"co:2345:respawn:/sbin/mingetty console" to /etc/inittab of guest


I tried that with no success :-(
Tried on both Jailtime Centos 4 and 5 under FC7.

These works well under FC6 recompiled Xen guest images (as it would NOT work with FC6 version)
Looks like moving domU onto other (or newer) dom0 is far from an easy task.

Anyone with a success story to share?

On 6/18/07, *Marcel Schroers* <schroers@xxxxxxxxxxxxxxxxxxxxxxx <mailto:schroers@xxxxxxxxxxxxxxxxxxxxxxx>> wrote:

    Hi *,

    as this is my first post I want to say hello to everybody.

    Well, and unfortunatly I've already got a question for you:

    I've installed a guest domain (OS: CentOS 4) on my xen-machine and
    it's para-virtualised (just to provide the information ;) ).

    After the installation and mount the image containing the guest to
    the necessary modules for the xen-kernel, umount it and boot the
    guest domain with
    the xen-kernel. Everything seems fine except that udev seems to not
    create any
    console/tty or similar. Heres a snipped of the boot log:

                     Welcome to  CentOS release 4.5 (Final)
                     Press 'I' to enter interactive startup.
    Starting udev:  [  OK  ]
    Initializing hardware...  storage network audio done[  OK  ]
    Configuring kernel parameters:  [  OK  ]
    Cannot access the Hardware Clock via any known method.
    Use the --debug option to see the details of our search for an access
    Setting clock  (localtime): Mon Jun 18 12:04:30 CEST 2007 [  OK  ]
    Loading default keymap (us): [FAILED]
    Checking root filesystem
    [/sbin/fsck.ext3 (1) -- /] fsck.ext3 -a /dev/sda1
    /: clean, 34637/512000 files, 241019/1022127 blocks
    [  OK  ]
    Remounting root filesystem in read-write mode:  [  OK  ]
    no block devices found
    Setting up Logical Volume Management: [  OK  ]
    Checking filesystems
    Checking all file systems.
    [  OK  ]
    Mounting local filesystems:  [  OK  ]
    Enabling local filesystem quotas:  [  OK  ]
    Enabling swap space:  [  OK  ]
    INIT: Entering runlevel: 3
    Entering non-interactive startup
       No volume groups found
    Checking for new hardware [  OK  ]
    Starting pcmcia:  [  OK  ]
    Setting network parameters:  [  OK  ]
    Bringing up loopback interface:  [  OK  ]
    Bringing up interface eth0:  [  OK  ]
    Starting system logger: [  OK  ]
    Starting kernel logger: [  OK  ]
    Starting portmap: [  OK  ]
    Starting NFS statd: [  OK  ]
    Starting RPC idmapd: [  OK  ]
    Mounting other filesystems:  [  OK  ]
    Starting automount: No Mountpoints Defined[  OK  ]
    Starting smartd: [FAILED]
    Starting cups: [  OK  ]
    Starting sshd:[  OK  ]
    Starting xinetd: [  OK  ]
    Starting sendmail: [  OK  ]
    Starting sm-client: [  OK  ]
    Starting console mouse services: no console device found
    Starting crond: [  OK  ]
    Starting xfs: [  OK  ]
    Starting anacron: [  OK  ]
    Starting atd: [  OK  ]
    Starting system message bus: [  OK  ]
    Starting HAL daemon: [  OK  ]
    INIT: Id "co" respawning too fast: disabled for 5 minutes
    INIT: no more processes left in this runlevel

    There are some error-messages which compplain about not finding any
    I would normally try to make some new ttys with mknod but
    unfortunatly I can't
    even login to the quest, after the last line the guest seems to hang
    (the last two
    lines beginning with "INIT" appear after a short time (about 2mins or

    I've already searched here at the mailing list without success. I
    hope I do not double post
    a problem which is already known and solved (in this case maybe would
    somebody post me the link
    to the solution?)

    Thanks i advance for any help.

    Best Regards,

    Xen-users mailing list
    Xen-users@xxxxxxxxxxxxxxxxxxx <mailto:Xen-users@xxxxxxxxxxxxxxxxxxx>


Xen-users mailing list

Frank Morane (Free Thinker)

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.