[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Hypervisor does not start?

> I have a curious problem:
> a few month ago i set up a root server located at my provider. This
> server has a serial console so that I can see the boot messages.
> Last week I had to reboot the server and it does not start again! 

Maybe some kind of update whilst the machine was up has broken the 

> After 
> a few tries I initialized it with a new, fresh Debian, compiled Xen 3.1
> and used the old kernel-config. The config of the kernel which worked.
> The server does not start with the new kernel! But there is no message
> like "kernel panic - can't mount root fs" or something else. There's
> only the menu from grub, a message that it begins to boot but not any
> more. I think the Hypervisor itself does not start?!

Can we see your menu.lst?

> But why? 
> I tried older versions from Xen but with the same result.
> When I mount the harddiscs with a rescue-system I can't find any log
> entries. A non-xen kernel boots without any problems.


Are you sure it's not just something basic? (e.g. you forgot to configure Xen 
in menu.lst to output to the serial console, and so you're not getting any 
messages from it)

> Is it possible that one of the two processors has a damage? Possibly Xen
> calls functions of the processor which a non-xen kernel does not use?
> The next days  I will run a memory check to except the RAM as a cause...

I suspect it's a software change or a configuration problem rather than 
anything the matter with your hardware.


Dave: Just a question. What use is a unicyle with no seat?  And no pedals!
Mark: To answer a question with a question: What use is a skateboard?
Dave: Skateboards have wheels.
Mark: My wheel has a wheel!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.