[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Boot error with 2.6.23 domU

> > To boot under Xen you need to use a vmlinux / vmlinuz image.  Were you
> > guys perhaps trying to use the bzImage?  That won't work (yet).
> >
> > The vmlinux that's in the root of your kernel build tree ought to work. 
> > I stripped and gziped mine to get a much, much smaller vmlinuz file and
> > used it to boot a Xen domain for the first time last night - worked fine.
> I tried vmlinux, but also, it didn't work.
> It hanged at:
> # xm create -c somedomain
> Using config file "/etc/xen/somedomain".
> Started domain somedomain
> And it seems to wait there forever.

It's just not outputting to the console.

In the domain config file add "console=/dev/hvc0" to the extra= line in order 
to append this to the kernel command line.  Then you ought to see the usual 
boot output.


Dave: Just a question. What use is a unicyle with no seat?  And no pedals!
Mark: To answer a question with a question: What use is a skateboard?
Dave: Skateboards have wheels.
Mark: My wheel has a wheel!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.