[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Boot error with 2.6.23 domU

Mark Williamson schrieb:
To boot under Xen you need to use a vmlinux / vmlinuz image.  Were you
guys perhaps trying to use the bzImage?  That won't work (yet).

The vmlinux that's in the root of your kernel build tree ought to work. I stripped and gziped mine to get a much, much smaller vmlinuz file and
used it to boot a Xen domain for the first time last night - worked fine.
I tried vmlinux, but also, it didn't work.

It hanged at:

# xm create -c somedomain
Using config file "/etc/xen/somedomain".
Started domain somedomain

And it seems to wait there forever.

It's just not outputting to the console.

In the domain config file add "console=/dev/hvc0" to the extra= line in order to append this to the kernel command line. Then you ought to see the usual boot output.

I'm not sure.
Even when I add this line, I don't see anything in the console.

Moreover - even if I wait a bit, I can't ping that host.

Also, with 2.6.18 domU kernel, without a valid initrd/ramdisk, the guest would just do a kernel panic, and the domain would be automatically destroyed.
With 2.6.23 domU, I don't see anything like this.

Tomasz Chmielewski

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.