[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Xen with LVM

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "IDAGroup - R.W.Muller" <robin@xxxxxxxxxxx>
  • Date: Thu, 11 Oct 2007 14:19:26 -0400
  • Delivery-date: Thu, 11 Oct 2007 11:20:45 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hello everybody, new in the Country (coming from Switzerland) and new to Xen as well :)

I tried to install the first CentOS 5.0 - XEN -LVM machine but struggle somehow. I followed
the explanations of
Paul, but CentOS 5 seems to have a problem with mounting the LVM after installation:


When I create a new lv named centos5 and do a  mke2fs /dev/vm-data/centos5
I can easily mount the "drive" with mount /dev/vm-data/centos5 /mnt/centos5. I unmounted centos5 then
and started the virt-install. Said for path /dev/vm-data/centos5 and no graphics. Pretty soon the installer
comes up with "/dev/xvda currently has a loop partition layout.  To use this disk for the installation of CentOS, it must be re-initialized.."
I allow this but create my own partitioning (one Ext3 partition mounted as / with full lv size).
Right after this step, the lv is no longer mountable and when checking the "drive" says wrong superblock.

Is there an issue with LVM on Centos5, or did I do something wrong? ....tried everythign for several hours now :/

[root@serv106 ~]# rpm -qa |grep lvm

I was also considering using file based domU's but still not sure if they would give enough performance for a webhosting (LAMP) server.

Any help, hint or even URL that leads to an actual working howto is greatly appreciated!

Thank you so much and have a great day now!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.