[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] USB Support for DomU - pciback.hide Problem

Hey everybody,

i have a problem getting the usb interface running in my domU. I successfully booted my dom0 and the log says "/pciback 0000:00:1d.7: seizing device" (so did the parameters in grub.conf etc.) / I also successfully started the virtual machine (domU) with "xm create xmDebian pci=0000:00:1d.7" with no errors. BUT when i connect to the domU machine and make a "lspci" it shows nothing...no devices...

The Log of the VM (domU) says:
Oct 14 17:53:38 kernel: Allocating PCI resources starting at 10000000 (gap: 04800000:fb800000)
Oct 14 17:53:39  kernel: PCI: setting up Xen PCI frontend stub
Oct 14 17:53:39  kernel: pcifront pci-0: Installing PCI frontend
Oct 14 17:53:39  kernel: pcifront pci-0: Creating PCI Frontend Bus 0000:00
Oct 14 17:53:39  kernel: PCI: System does not support PCI
Oct 14 17:53:39  kernel: PCI: System does not support PCI

Can anybody help me getting the usb-interface running in my domU?
Iam Using eisxen as dom0 but it doesnt make any difference to any other xen-system as i think. As DomU i tried debian and eisfair.

in domU: If i do a "cat /proc/bus/pci/devices" it also shows nothing...(there is no /proc/bus/usb/devices)

I might forgot to mention that when i run lspci in Dom0 it shows me the "hided" usb device. Isnt it supposed to be hidden?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.