[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] PPPoE in DomU exits with error

  • To: <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "[STD]Ein" <ein@xxxxxxxxxxxxxx>
  • Date: Wed, 21 Nov 2007 16:20:54 -0600
  • Delivery-date: Wed, 21 Nov 2007 14:21:44 -0800
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcgsQ7fptLOpjwR+RBOFQCbfpdJlpwAR9pmQ

Here's what I 'can' tell you.

My previous setup used Debian Etch as the dom0, pciback to pass a nic to a
domU, and Smoothwall 3.0 firewall distro as the domU.  I used the Xen
provided Redhat kernel package for the domU, since Smoothwall is a fork from
old Redhat, and copied the modules from it into the domU.

It just worked.  Then, I just recently dist-upgrade'd to Lenny, and
installing the Xen 3.1 hypervisor, staying with the existing 3.04 kernels
(2.6.18-5-xen-686), and it still works.

I suspect your problems lie strictly with pppoe and not Xen, you might want
to try hitting up the Roaring Pengiun forums (do they have a list?) and see
what they can tell you.  Of course, I'm no guru, I just pretend to know what
I'm doing, so take my advice/info with a grain of salt.

-----Original Message-----
From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
[mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of kanour-xen
Sent: November 21, 2007 7:37 AM
To: Christian Lyra
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] PPPoE in DomU exits with error

kanour-xen wrote:
> Christian Lyra wrote:
>>>>> I am trying to setup my firewall in DomU. However, I have got a
>>>  >>> little problem. My *pon dsl-provider *exits with following
>>>  >>> message.
>>>  > My firewall is a domU too, but it has control of the interface
>>>  > connected to the internet, and pppoe works just fine. never tried
>>>  > to do this with a bridge...
>>>  >
>>>  What do you mean by domU has control over the interface?
>> I "hide" the interface from dom0 with pciback.hide=(xx:xx.x) in grub 
>> and present it to domU with pci = [ 'xx:xx.x' ]. So the domU has 
>> control of the real pci device.
> I tried that already, but when I included pciback.hide=(xx:xx.x) in grub 
>  the card was still present. So, I then unbound it from /sys/...
> I included pci =[..... and started domU. It was still the same.
> At this moment I don't know what to do, but I will try to reinstall 
> everything and try one more time with Debian Etch xen binary packages.
> At this moment I am using Debian Lenny with binary xen from XenSource.
> I am just wondering why the hiding with pciback.hide does not work for me?
> Jiri
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

So, I did reinstall everything to Debian Etch. I am running xen from 
debian packages. But I just cannot make the pppoe work.

Please help!!!

I did hide the pci device on the boot. I checked that the driver (e1000) 
is not loaded in Dom0.
I included pci statement in DomU config file. I checked that the devide 
was recognised and driver was loaded in DomU.

I have it all on HP DL145 G2 server. There is AMD dual core processor, 
2GB ram, 2x Broadcom network card and I added Intel PCI card in the 
raiser board (PCI-X).

pppoeconf will discover pppoe on eth2 (intel 1G card) but when it tries 
to establish the connection. it fails with:

    Nov 18 09:44:40 alsfw01 pppd[1723]: Plugin rp-pppoe.so loaded.
    Nov 18 09:44:40 alsfw01 pppd[1723]: Linux kernel does not support
    PPPoE -- are you running 2.4.x?

Could anyone help me to troubleshoot it.
skype: linuxgo


Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.