[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Re: [Xen-users] Xen 3.1.0 and openSuse 10.3 - xenbr0 won't dissapear

Thanks for an advice, it is a good idea and I tried it. But it still didn't solve my problem. It is the same like before, when xend starts, it creates an empty xenbr0 (just a bridge, with no interfaces on it and with no virtual interfaces like veth, peth or vif0.x). I tried to read all xen scripts related to bridging, but I didn't find a single clue, why is xend doing it. It is like the program itself has somewhere stored a simple "brctl addbr xenbr0" command and executes it everytime it starts up.
Lukas Pecha

LukÃÅ Pecha schrieb:
I use xen for a few months now and I upgraded to opensuse 10.3 with xen
3.1 (64bit versions) recently.
Everything works fine, but there is a problem when I change
xend-config.sxp to use my own network script (it's slightly modified
version of network-virtual scripts from
http://en.opensuse.org/Xen3_yet_another_Virtual_Network_Concept )
instead of default network-bridge script. The problem is, that after


Put your script instead of xend-config.sxp into a new init.d-script and
add it's name to the line "Required-Start" in the file /etc/init.d/xend
I have also set the "RUN_PARALLEL" in /etc/sysconfig/boot to no.
In xend-config.sxp you need to put a dummy network-bridge script ( only
a "exit 0" inside). Then you can have a complex network as you want!
With this modification's my xen-network is always starting with all
elements, 2-3 'normal' bridges and 2-4 vnet's with peering between two
datacenters.. :-)

Robert Valentan

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.