[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] GPLPV drivers 0.9.12-pre9 upload

  • To: "James Harper" <james.harper@xxxxxxxxxxxxxxxx>
  • From: "Andrew Lyon" <andrew.lyon@xxxxxxxxx>
  • Date: Wed, 24 Dec 2008 11:27:17 +0000
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Wed, 24 Dec 2008 03:27:48 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:cc:in-reply-to:mime-version :content-type:content-transfer-encoding:content-disposition :references; b=BSVf235ZFeBwx2Dab2Mjoya7w0JHw2hILANT/t5QUm5194v8Ghgg7B2l4Hj8riItM/ wuvg6Zt9GMbBTJDARNNuIn5E9+sq4PYyEPhHGJJ5WDHy5x59+oeBBo/zJHDoL3LvRWd8 DDep2TG+UfGJWkd1Fj7QS/lzZRv4D3EPGLUTU=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

On Wed, Dec 24, 2008 at 5:35 AM, James Harper
<james.harper@xxxxxxxxxxxxxxxx> wrote:
>> > 3. If you are using the latest Xen 3.3.1 hg (maybe 3.3.0 too?), the
>> > qemu_disable_patches.diff patch applied to the ioemu-remote git repo
>> > (after 'make tools' has downloaded it, or after you've updated it to
> the
>> > latest) will completely remove the ide disks and network interfaces,
>> > leaving the cdroms as emulated by qemu. This is how things should be
>> > going forward - qemu cdrom's means you get eject and virtual image
> swap
>> > etc, and performance on a cdrom is hardly critical. Hopefully these
>> > patches will make it into Xen 3.4.
>> I posted this earlier in the wrong thread, I tried to use the
>> qemu_disable_patches.diff today with 3.3.1 rc4 but it didn't hide the
>> devices or change cdrom to emulated when using the pre11 drivers, this
>> is what I did:
>> hg clone -r 3.3.1-rc4 http://xenbits.xensource.com/xen-3.3-testing.hg
>> cd xen-3.3-testing.hg
>> make tools # I believe this is necessary to pull ioemu-remote ?
>> cd tools/ioemu-remote
>> patch -p1 -i /usr/src/qemu-pci-disable.patch # I removed the last
>> chunk of the patch which changes vl.c as the changes are in 3.3.1-rc4.
>> make clean
>> cd ../../
>> make clean
>> make tools
>> make install-tools
>> /etc/init.d/xend restart
>> I did not recompile xen, only the tools.
>> In my vista hvm the Intel IDE and Realtek NIC are still visible, and
>> cdrom is XEN PV not ioemu/qemu.
>> Is my method incorrect?
> It looks to be. Can you confirm that the qemu-dm installed by 'make
> install-tools' is definitely the one being used by your domain?

The method I used does not work, it appears that after patching and
recompiling the binary does not get updated, it is the same as the one
produced by the first "make tools".

Instead I started from scratch and immediately after "make tools"
downloaded ioemu-remote git I paused the process, applied the patch,
and then resumed, this time the binary is different, and in my vista
vm the devices have changed, but they are still not correct, both are
now emulated:

Realtek RTL8139C


> One of the other changes is that logging should appear in the logfile
> for that domain. Can you have a look there and see what's in there?
> Thanks
> James

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.