[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] terrible problems with Xen on SLES 10.2 / 11

  • To: "Fajar A. Nugraha" <fajar@xxxxxxxxx>
  • From: Marcin Krol <mrkafk@xxxxxxxxx>
  • Date: Mon, 01 Jun 2009 15:25:33 +0200
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Mon, 01 Jun 2009 06:26:18 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:user-agent:mime-version:to:cc:subject :references:in-reply-to:content-type:content-transfer-encoding; b=YJ3fUaQRR6TLsdP8pXug5PFe3ifr0R0tLbGwY/xYXn/DoH2X0B/2qbYu3689KeRRBp 6SdKTwZTGiuntBlt8F+CqF5hOYASb8zHhht0G9AZe7j4TxJFV2zNJgEXKk7KS17ghVe3 OwKl3q91EeEw/Xue0P8pD44Gpqjs4n6ED66Ag=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hello Fajar,

Thanks for answer!

Fajar A. Nugraha wrote:
I'm totally new to Xen and trying to run it on some platforms (x86, x64)
using SLES (that is what I have to use for reasons other than technical).

Not the best reason :P

I know :-( :-P

If you're using it as domU then you should be able to use any distro
that you're familiar with as dom0. My favorite is RHEL5.

Trouble is, I tested with RH5 (.1, .2, .3) just to make sure there is nothing else wrong and I couldn't get it working either! That is, either network in the dom0 (that is, main/host domain IIRC?) doesn't work at all or kernel can't communicate with the disk and throws up lots of SCSI errors.

Several machines on which I tried using Xen simply fails to run normally
using Xen kernel: either network communication is not functioning at all
despite proper configuration (that works on non-Xen kernel), or the kernel
can't communicate with disks, issuing SCSI bus reset commands in loop (and
failing to reset it).

What is your xen setup like? Which part is experiencing problems:
dom0, PV domU? HVM domU?

I simply chose "Install hypervisor and tools" in YAST, changed kernel in /boot/grub/menu.lst to Xen-enabled and reboot. Regardless of what machine I try this on, it doesn't come back.

Hardware is mainly made by IBM (xSeries with older Xeon or Opteron CPUs).

While booting Xen kernels on SLES they have following symptoms:

- various FATAL errors while loading modules, like missing xen_vbd or
missing xen_vnif

- when booting non-xen kernel, messages in dmesg like:

xen_vnif: Unknown symbol balloon_update_driver_allowance
xen_vnif: Unknown symbol balloon_release_driver_page

Again, what is your setup like?

Clean install of SLES 10.2 or 11, on physical machine, failing to get dom0 working.

xen-vnif and xen-vbd are PV drivers for Linux HVM domU. You do NOT
need them for dom0 or PV domU.

Good to know.

I can't fathom what is going wrong then. I'm currently trying to get dmesg output saved, but I have to wait some 30 minutes to get it, bc kernel throws various SCSI errors and tries to reset and it takes a long time for it to fall back into single user. When I get dmesg output, I'll post it here.

Besides, AFAIK they only work for
kernel 2.6.18.x, not for newer kernels.

Is it perhaps a HVM domU converted to physical machine?

No. It is plain SLES installed on physical machine, which I then try to enable to run Xen kernel.

Or is it a
machine upgraded from older suse version?

It is not upgraded either, it is clean install every time (and I tried it on several machines, from IBM Netvista with P4 through Thinkcentre with P4 through xSeries with Xeon and xSeries with Opteron).


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.