[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] Hotplugging SCSI device to Windows 2k3 GOS

> Hi,
> I am trying to do a scsi hotplug to a Windows GOS using the xm
> command.
> This is my configuration
> RHEL 5.2 DOM0 with Xen 3.3
> 32 bit Windows 2k3 GOS with WindowsXenPV-0.9.4 installed. boot.ini has
> added
> I have a SATA harddisk which I am tryng to hotplug to win GOS. The
output of
> lsscsi is as below
> #lsscsi
> [0:0:0:0]    disk    ATA      ST380013AS             3.18  /dev/sda
> [1:0:0:0]    disk    ATA      WDC WD2500YS-01M 02.0  /dev/sdb
> and I am using the below command to attach /dev/sdb to GOS
> # xm list
> Name                                        ID   Mem VCPUs      State
> Time(s)
> Domain-0                                    0   512     8
> 3381.5
> Windows2003                               5   256     1         -b----
> #xm scsi-attach Windows2003 1:0:0:0 1:0:0:0
> #
> As soon as I run the above command, I see a pop up coming in Win2k3
> indicating that a xen vscsi device is hotplugged. But when I go to the
> Manager in Windows and look at this device, it appears with an Yellow
bang and
> the driver tab indicates error Code 10 (reinstall driver).
> I tried this multiple times, but always end up at the same state. Have
> tried something similar ? Do you know what might going wrong here ?

It should work, it certainly used to. Can you please run DebugView from
sysinternals.com on your windows machine, turn on kernel logging, then
try the hotplug? That should capture some debug logging. Email it to me
and I'll have a look.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.