[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Unable to communicate with TPM on domU

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Nicolas Muñoz <nicolas.munoz.zz@xxxxxxxxx>
  • Date: Mon, 13 Jul 2009 15:44:01 +0100
  • Delivery-date: Mon, 13 Jul 2009 07:44:46 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=VUkXemqyUMk4cNbgNSuWIvmLyZygwsf2gps+HS3NjTJxGVJY7btxBdfJqLLWqB5/OC cxwApHmBl7Fnr5RCs1kQw1hjYdYBSjt8jXWkyf4Y6AzWxZGu4ezgi/bZ77iEwucAv8+H VKTjgiEsL+smr2vXxeUf2XqL01XfVkCboaxzY=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


I am currently running a Debian lenny on top of a Ubuntu 9.04 dom0. (Xen version is 3.4)
Now I want to test some tpm functions in the domU, but I am having troubles reaching the TPM. To do so, I am following the tutorial here :


I have already used this tutorial on a non-virtualised machine, and even on my dom0, and I managed to communicate with the TPM without any problem. So here is what I do, and what goes wrong :

- apt-get install tpm-tools trousers
- modprobe tpm_bios
- modprobe tpm

So far, no problem. Here, if I follow exactly the tutorial and type

- modprobe tpm_tis force=1 interrupts=0

I get the following error message :

FATAL: Error inserting tpm_tis (/lib/modules/ Input/output error

When I look at dmesg, the displayed message is not the one expected :

pnp: the driver 'tpm_tis' has been registered

If I just run

- modprobe tpm_tis

I do not get any error message, but when I run dmesg, I get the same disappointing message (According to the tutorial, the message should be something like 

 [xxx.yyy] tpm_tis tpm_tis: 1.2 TPM (device-id 0x4A10, rev-id 78)

which is what I get when I follow the tutorial anywhere but on my domU.

Anyway, after having done this, if I try to communicate with the TPM, I get the following error message :

lenny-guest:/home/nicolas# tpm_version
Tspi_Context_Connect failed: 0x00003011 - layer=tsp, code=0011 (17), Communication failure

which seems to confirm that the modules are not loaded...

Yes, I checked if tcsd was started, first with

/etc/init.d/trousers status
tcsd is not running

Then I ran

/usr/sbin/tcsd start

which does not return any error message

But /etc/init.d/trousers status keeps saying tcsd is not started.

Indeed, I wanted to disassemble the ACPI table to see if something was wrong, but it seems that there is no 'acpi' folder in /proc. But actually, as it works on the dom0, there should be no problem, because it proves that my TPM is supported by tpm_tis...

I think I detailed all I know about it, do you have any idea..?
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.