[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Can't get Dom0 PV_OPS working properly

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Ian Murray <murrayie@xxxxxxxxxxx>
  • Date: Sat, 15 Jan 2011 10:25:07 +0000 (GMT)
  • Delivery-date: Sat, 15 Jan 2011 02:26:26 -0800
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.co.uk; h=Message-ID:X-YMail-OSG:Received:X-Mailer:References:Date:From:Subject:To:In-Reply-To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=VWzo/vXXt7d3g+ibsnEZm95pHO4mOQmRfcr+IYXTIQpmGAZ9svAPVTBlaaugmLT4h3QT1GP69BsSEdsdOViSNld4B6I8HHLecvVbahbJIUSyN+Kuk0OAZ8+FHh8R7tFGJJYU8ohwgi6/bD2Sf83n/1MiwF11GnAwmk9hvtNie2Q=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

> CentOS 5.5 w/ Xen from GitCo
> The odd thing is if I  start xend using the service (init.d) script, I don't 
> xenconsoled  running. If I run the executable with 'start', i.e. 
> /usr/sbin/xend 
> start,  then xenconsoled starts up. Going through the init.d script now to 
> see 
> I  can spot where one calls the  other.

Basically, having introdiced pauses in the python xend, I have discovered that 
when launched via the xend init.d script, xenconsoled goes <defunct> according 
to ps aux|grep xen.

It even goes <defunct> when I run the following script:-


/usr/sbin/xend start

Yet, if I type in "/usr/sbin/xend start" it starts fine.

I have since got the console working... removed the console= line completely.

The other issue is that it is failing to reboot properly if I have started 
xenconsoled. After the "restarting message", I am getting some kind of stack 
trace being dumped out.

I am starting to question the whole reliability of what I am try to do here.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.