[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Strange Halt during Xen boot

  • To: Steven Timm <timm@xxxxxxxx>
  • From: Bill M <bill4306@xxxxxxxxx>
  • Date: Sun, 6 Feb 2011 14:21:21 -0500
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Sun, 06 Feb 2011 11:22:17 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=MmYk2nXoujsSgbr9XNe0WB+yk5+lOpVGKQJl58psZzfYo8BJ5Xcuinaqq1C+PpW3OJ 5Zjqu7VNUv4D9hh8dZKSwVPz9hNeRO5TJDDKQcoSe7eOvykd4+KS2l1R03mT01KQO7Cu gRlCkQdS1itAsCCuvru3YJjuCO05qrh4Hoorc=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Thanks for the note, Steve. Here is my grub.conf:

serial --unit=0 --speed=115200 --dumb
terminal --timeout=5 serial console
title Xen-CentOS (Xen-3.4.1, vmlinuz-
        root (hd0,1)
        kernel /boot/xen.gz
        module /boot/vmlinuz- ro root=UUID=c25415f0-1eff-4b3e-a03b-99c3fecbbe57 console=tty0 console=ttyS0,115200 selinux=0
        module /boot/initrd-
title CentOS (2.6.18-194.8.1.el5)
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.18-194.8.1.el5 ro root=UUID=c25415f0-1eff-4b3e-a03b-99c3fecbbe57 console=tty0 console=ttyS0,115200 selinux=0
        initrd /boot/initrd-2.6.18-194.8.1.el5.img

I think I have included the serial console on the module line for dom0(console=ttyS0,115200), but please correct me if I'm wrong on this. I tried to add "console=tty0 console=ttyS0,115200" to the line of "kernel /boot/xen.gz", but still no output from the hypervisor.

You made a good point that 2.6.18-8 kernel is indeed quite old, and may not support the hardware on R710. Actually, I don't really mind which version of Xen I should use for my setup. I tried the stock Xen(the rpm is 3.0.3) on CentOS 5.5(with yum groupinstall), but still got the same result. Is there any option I should add to the kernel line to get some output from the hypervisor? so far I have tried "watchdog sync_console" but none is working.


On Sat, Feb 5, 2011 at 8:31 PM, Steven Timm <timm@xxxxxxxx> wrote:
How is your grub.conf set up.. it may be that there are other
errors that are visible only on the serial console and not on tty0.
2.6.18-8 is a pretty old kernel for R710 architecture. the redhat/centos
built kernel with centos 5.5 allows for new hardware architectures like
Nehalem which the source that comes in 2.6.18-8 kernel might not.

I am running the stock xen and kernel that come with Sci.Linux 5.5
(another RH clone) which as others have mentioned is 3.1.2 even though
the rpm says 3.0.3.  Are there some 3.4 features that you need
that aren't in the stock xen/kernel.

Steve Timm

On Sat, 5 Feb 2011, Bill M wrote:


I'm trying to get Xen 3.4.1 working on CentOS 5.5(64bit) for a Dell R710
box(Quad Core Xeon "Nehalem" processor, 12 GB Memory and 2 Seagate SATA HDD).
I followed the README to make world, make install, generate the
corresponding ram disk with initrd, and modified /boot/menu.lst. I believe I
didn't make any mistake through these steps, because I was able to get Xen
3.4.1 running on CentOS 5.5 for a Dell  Optiplex 745 box (Intel Core 2 Duo
E6600, 2GB memory and 1 SATA HDD) with the same procedure.

However, for the R710 box, once I reboot the server and boot with Xen, the
system enters a halt that lasts forever, and all I got on the console was

Booting command-list

root (hd0,1)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/xen.gz
 [Multiboot-elf, <0x100000:0x11f770:0x6b890>, shtab=0x28b078,
module /boot/vmlinuz- ro
be57 console=tty0 console=ttyS0,115200 selinux=0
 [Multiboot-module @ 0x28c000, 0x73b340 bytes]
module /boot/initrd-
 [Multiboot-module @ 0x9c8000, 0x48ebc00 bytes]

No error message at all... So my guess is that the system halts right after
the grub loading. But, has the hypervisor booted? what causes the halt?

I have tried three different ways to get Xen working on my R710 setup, but
they all ended up with the same bizarre output.
1) Building from source for Xen 3.4.3, Xen 3.3.2, Xen 3.1.4;
2) Using yum to install binary for Xen 3.4.3, Xen 3.0.3 (the stock Xen comes
with CentOS 5.5) (I came across a post here mentioning someone successfully
get Xen 3.0.3 (CentOS 5.4) running on R710).
3) Building linux- with the existing CentOS kernel configuration
file. I copied the existing configuration file into
the build-linux-2.6.18-xen_x86_64 directory and followed the README on how
to build the kernel with .config under the build-linux-2.6.18-xen_x86_64
directory. For all remaining configure questions during compiling, I chose
the default option.

Up to this point, I'm totally clueless on how to solve this problem. Has
anyone seen this problem before, or any insight to share? I would really
appreciate the help.


Steven C. Timm, Ph.D  (630) 840-8525
timm@xxxxxxxx  http://home.fnal.gov/~timm/
Fermilab Computing Division, Scientific Computing Facilities,
Grid Facilities Department, FermiGrid Services Group, Group Leader.
Lead of FermiCloud project.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.