[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] upgrade leny-squeeze, xen3.2-xen4.0, what's wrong?

  • To: xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: Mauro <mrsanna1@xxxxxxxxx>
  • Date: Thu, 10 Feb 2011 08:16:09 +0000
  • Delivery-date: Thu, 10 Feb 2011 00:17:29 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=h7OWg6o6cdeVpF2SzYp4uQH+fd2WKr/78KBYrLX+cSEopxM3EoaTYmqUCJ/52K0fGY /G9FzoDpoESdak0i1seTEoeTLoJMgZg2ztVnmHbSZVVNrY7aF7Hkl58WvhiZLEQSQUkT v8nLmF7ceijT/Vfd9mp8mpClOJ14pzydgZSLo=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I am running a Debian Squeeze Xen 4.0.1 Hypervisor and 2.6.32-5-xen-amd64 dom0.
My xen-tools.conf:

lvm = vg00
size   = 100Gb      # Disk image size.
memory = 2048Mb    # Memory size
swap   = 2G    # Swap size
# noswap = 1      # Don't use swap at all for the new system.
fs     = ext4     # use the EXT3 filesystem for the disk image.
dist   = `xt-guess-suite-and-mirror --suite` # Default distribution to install.
image  = sparse   # Specify sparse vs. full disk images.

gateway    =
netmask    =
broadcast  =

kernel = /boot/vmlinuz-`uname -r`
initrd = /boot/initrd.img-`uname -r`

arch = amd64
mirror = `xt-guess-suite-and-mirror --mirror`

ext4_options     = noatime,nodiratime,errors=remount-ro
ext2_options     = noatime,nodiratime,errors=remount-ro
xfs_options      = defaults
reiserfs_options = defaults
btrfs_options    = defaults

# serial_device = hvc0 #default
# serial_device = tty1
# disk_device = xvda #default
# disk_device = sda

then I run as usual:
xen-create-image --hostname mail1 --ip --vcpus 4 --role
udev --dist squeeze

at the end of domU creation I run xm console mail1 but here is what I see:

Begin: Waiting for root file system ... done.
Gave up waiting for root device.  Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT!  /dev/xvda2 does not exist.  Dropping to a shell!

I think there is nothing wrong in my creation procedure, I have a lot of
DomU with debian lenny and xen3.2.
Perhaps ext4 isn't supported?
Help please.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.