[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen3 domU on xen4 dom0

On 10.02.2011 06:19, Henrik Langos wrote:
On Wed, Feb 09, 2011 at 02:17:10PM +0100, Wolfgang Grossbauer wrote:
On 08.02.2011 17:26, Henrik Langos wrote:
On Tue, Feb 08, 2011 at 03:26:50PM +0000, Todd Deshane wrote:
On Tue, Feb 8, 2011 at 2:17 PM, Wolf Grossi<wg@xxxxxxxxxxxxxx>   wrote:

Trying to to run a xen3 domU on a xen4 dem0 I run into problems.

xm create -c M08
I get the following error:

XEN1:/etc/xen/vm # Error: (2, 'Invalid kernel', 'elf_xen_note_check: ERROR:
Xen will only load images built for Xen v3.0\n')

I do not uderstand the above error: the kernel to be loaded *is* a xen-3.0
kernel and should be taken from domU:/boot.

Now I have the following questions:
1) Can I run xen-3 domU's on a xen-4 dom0?

Yes. I am running a Debian Squeeze Xen 4.0.1 Hypervisor and 2.6.32-5-xen-amd64 

On that I run a couple of older PVM machines that have an 2.6.26-2-xen-686 
That is a 32bit kernel compiled for xen 3.2-1.

Tomorrow I'll try to get my old Etch VMs there too. (2.6.18 32bit domU made for 
Xen 3.0.3)

2) If yes (hope so :-), what's wrong with the above install/config,
    or what have I missed?

I guess your pygrub doesn't find the right kernel on your VM's disk image.

Try to mount the image in dom0, copy the kernel and initrd to /boot/foo/

Edit your config file /etc/xen/vm/M08 and replace

   bootloader      = '/usr/lib/xen-default/bin/pygrub'


   #bootloader      = '/usr/lib/xen-default/bin/pygrub'
   root = '/boot/foo/vmlinuz-blah'
   ramdisk= '/boot/foo/initrd-blah'

Don't forget to umount the VM's disk image and try again
xm create /etc/xen/vm/M08

Good luck :-)

You need the "top" Xen version to run as an HVM guest on the bottom
Xen. So, for your case, make your Xen3 Xen domU an HVM domain. That
should work.

Hope that helps.


AFAIK pygrub is only for PVM, isn't it? So I assume that Wolf tries
to get an older PVM guest to run on a relatively recent hypervisor/dom0


Yes, exactly;
I'm trying to run a xen3 paravirt guest (32 Bit)
on a xen4 (64 Bit).

I am doing the same thing here. It even works with _very_ old 2.6.18 kernels
made for xen 3.0.3. Tried it yesterday and it works like a charm.

I applied your suggestions, however still the same problem:

xm create M08
Using config file "/etc/xen/vm/M08".
Error: (2, 'Invalid kernel', 'elf_xen_note_check: ERROR: Xen will only
load images built for Xen v3.0\n')

M08 config for xm:
root = '/boot/vmlinuz-'
ramdisk= '/boot/initrd-'
disk= [ 'file:/root/M08.raw,xvda,w' ]

Aaaaahhh. My bad!  It is not "root" but "kernel".

It should have been

kernel = '/boot/vmlinuz-foo'
ramdisk= '/boot/initrd-foo'
root = '/dev/xvda2 ro'
disk= [ 'file:/root/M08.raw,xvda,w' ]

But wait a second ... 2.6.11 ??? What is this? The dark ages? ;-)

I am pretty sure that 2.6.11 was not a xen 3 kernel.


PS: Please use "reply-to-all" to have your reply also on the list.
Maybe somebody else will find this in the mailing list archive
before trying to run a 2.6.11 linux on a 4.0 hypervisor.

Henrik, thanks a lot for your time!
Yes, you are right, it's a xen-2.something kernel.
So I guess I have to consider other alternatives (like dump that old stuff :-) .


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.