[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] centos 5.6 upgrade to 4.1 - no DomUs listed


Thank you for feedback to the list, good for searches!

It is interesting and strange that that worked. I am running CentOS 5.6 with the gitco Xen 4.1
and the libvirt is stock (not in gitco either):


I just tested a ubuntu 10.04 image and it booted just fine, not sure why. I am also not sure about
"the build", are you building everything from SRPMS?


On 5/19/2011 10:45 PM, Andy Howell wrote:
On 05/18/2011 07:46 PM, Randy Katz wrote:
Andy, looks like your image is not bootable, I have run into that, did not
try to fix one, however, did some some posts related if you search. Since then
I have created bootable images and have not had a problem loading them. If
all else fails create a new bootable image (using remote/network install or kickstart
or however) then mount the image, copy the data, and copy it to the bootable VM.


	I solved the problem I was having with the Virtual Machine Manager not showing guests,
running or not. I updated libvirt to 0.9.1 from the default CentOS 5.6 one.

libvirtd fails a test during the build, The attached trivial patch removes the failing
test. The test fails because of CentOS using an old version of libxml2.

I rebuilt with:

rpmbuild -bb --define='rhel 5' libvirt.spec

I've got a Ubuntu 10.04 guest running on CentOS now.

Hopefully this will help someone. ( or me when I forget what I did! )


_______________________________________________ Xen-users mailing list Xen-users@xxxxxxxxxxxxxxxxxxx http://lists.xensource.com/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.