[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re: Issues migrating to xen 4.1


Am 11.04.2011 03:07, schrieb Sylvain CHEVALIER:
Many thanks Pasi and Claudiu for helping and sharing.

I am sorry for not giving much more details about our experiences with
dom0 hanging, but I don't want to touch our server right now as it is
running fine (except for qemu-dm memory leak) and people are using it.
I hope to set up another server this week and experiment with it.
These issues were similar to what Claudu described, but again, after
applying the fixes I described, it has been working fine, and we did
not have to revert it to 4.0.

I think we had terminal issues, with any command run locally or
remotely in dom0 giving an 'input/output' error message), and we could
not establish any other connection to it.

I got here same Error after upgrading to xen-4.1 using 2.6.38-xen on gentoo. There are several domUs (gentoo, ubuntu, windows) running on this system it crashes without a kernel panic error just the 'input/output'-error.

There are 4 NICs bonded to bond0 with 3 VLANs bond0.1, bond0.11, bond0.12. The bridges are xvbr1 >> bond0.1, xvbr11 >> bond0.11 and xvbr12 >> bond0.12. I DONT use the xen-bridge-script because there is no need to build the brigdes. RAM 48GB, 2x quadcore CPU (Intel Xeon).

You said u fixed this issue with crashing, do u remember how? I am not really able to get informations out of all these "RE:" messages.

I really would be happy if u could tell me u fixed it.


We are using the latest kernel on gentoo: 2.6.34-xen-r4 and had
similar issues with the previous one (2.6.34-xen-r3).



On Mon, Apr 11, 2011 at 3:30 AM, Pasi Kärkkäinen<pasik@xxxxxx>  wrote:
On Sun, Apr 10, 2011 at 12:56:05PM +0800, Sylvain CHEVALIER wrote:

We just migrated xen on gentoo on amd64 from 4.0 to 4.1 and
encountered a few issues that were not documented. Here is how we
solved them and what issues are remaining:

1. Our config files were referring to the LVM devices like
/dev/vg/domU-root with disk = [ 'phy:vg/domU-root,sda1,w' ]. This does
not work anymore, we have to include '/dev/': disk = [
'phy:/dev/vg/domU-root,sda1,w' ].


I replied this 1. in another email.

2. We were using bridges to map the 4 ethernet cards to virtual
machines so that virtual machines could have their own IP addresses.
In xen 4.1, it is recommended to configure bridges by ourselves and
not use xend although xend would still work. We could not get the
bridges to work and went on using xend. However, the network-bridge
script now includes a test: if a bridge already exist, then it would
do nothing. The problem with that is that our wrapper script for
network-bridge would only create the first bridge. So we had to
comment out the test in network-bridge, and it would work. Did anybody
successfully create bridges on gentoo?
Meanwhile, we found that if a domU is started and tries to access a
bridge that does not exist, dom0 would stop working. Shall it be a

What do you mean dom0 would stop working? Network dies?
Does it work from the console?

And yes, it's recommended to configure networking using the distro
network scripts, see here for examples: 

3. I believe we have memory issues when running a windows domU. We use
to allocate 512MB to domU and found that qemu would quickly use most
of it and after a while, dom0 would stop working. Now we allocate 4GB,
made sure there is no ballooning and it appears to work fine. Memory
leaks by qemu are widely reported but I wonder why we did not have
such issues before xen 4.1 update.

Again what do you mean with dom0 would stop working? dom0 kernel crash? 
hypervisor crash?
And did you mean qemu-dm process in dom0 is leaking memory?

4. We might also have issues with CPUs. dom0 and all domU were
authorized to use all CPUs, and we saw the whole system freezing often
and quickly when mounting in charge after the 4.1 update. After we
spinned one CPU to dom0 we haven't seen this issue. Would this be a

This definitely sounds like a bug.

Please set up a serial console and capture the error/crash messages:

Also: what dom0 kernel version are you using?

Any hint or help on finding better solutions would be appreciated

-- Pasi

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.